Last modified: 2012-10-04 20:17:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22596 - Migrate subversion to git (tracking)
Migrate subversion to git (tracking)
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Git/Gerrit (Other open bugs)
unspecified
All All
: High normal (vote)
: ---
Assigned To: Chad H.
: platformeng, tracking
: 24213 27811 (view as bug list)
Depends on: 35497 35508 35534 27812 27813 33773 34137 34138 34140 34141 34349 34375 35139 35140 35141 35144 35145 35148 35209 35347 35359 35360 35381 35429 35455 35456 35460 35469 35510 35531 35532 35533 35535 35536 35537 35538 35574 35593 36168 36575 36873 40049
Blocks: tracking
  Show dependency treegraph
 
Reported: 2010-02-20 18:18 UTC by Bryan Baron
Modified: 2012-10-04 20:17 UTC (History)
15 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bryan Baron 2010-02-20 18:18:19 UTC
This is just to track the update.
Comment 1 Tim Starling 2010-02-26 00:42:50 UTC
Resolving "later" since we are not planning to do this any time soon.
Comment 2 Chad H. 2010-07-01 18:57:16 UTC
*** Bug 24213 has been marked as a duplicate of this bug. ***
Comment 3 Rob Lanphier (RobLa) 2010-07-01 20:36:21 UTC
A good primer for the Subversion adherents is "Subversion Re-education" from Joel Spolsky:
http://hginit.com/00.html

Don't pay any attention to the fact that it's talking about Mercurial and is pimping his Mercurial-based product.  The same DVCS virtues he extols apply to Git or Bazaar or probably even Darcs.

Now, as to *which* DVCS to switch to, here's a pretty persuasive case for Git:
http://blog.extracheese.org/2010/05/why-i-switched-to-git-from-mercurial.html

(...and I say this as someone who has been using Mercurial for the past couple of years)
Comment 4 Chad H. 2011-03-01 22:12:34 UTC
*** Bug 27811 has been marked as a duplicate of this bug. ***
Comment 5 Rob Lanphier 2011-12-19 22:44:30 UTC
This is being tracked here: http://www.mediawiki.org/wiki/Git_conversion
Comment 6 Sumana Harihareswara 2012-03-11 00:31:14 UTC
Update: the migration is happening on Wednesday, March 21st.
Comment 7 Rob Lanphier 2012-10-04 20:17:34 UTC
Closing blocking bug.  This is done, we have a component, and we're not really following this tracking bug anymore.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links