Last modified: 2012-04-12 19:30:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 35455 - Change Gerrit database schema to support utf8
Change Gerrit database schema to support utf8
Status: RESOLVED DUPLICATE of bug 35626
Product: Wikimedia
Classification: Unclassified
Git/Gerrit (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 35536 (view as bug list)
Depends on:
Blocks: 22596
  Show dependency treegraph
 
Reported: 2012-03-24 15:42 UTC by Chad H.
Modified: 2012-04-12 19:30 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Chad H. 2012-03-24 15:42:37 UTC
Right now, comments, commit summaries and everything fun is all stored with a latin1 charset in reviewdb. This is kind of annoying, especially when you're talking about fixing non-English bugs.

Hopefully it's just a matter of adjusting the CHARSET on each of the tables, but we'd like to test first of course.
Comment 1 Siddhartha Ghai 2012-03-24 15:50:19 UTC
See comment 1 in https://gerrit.wikimedia.org/r/#change,3505 for a comment using unicode.
Comment 2 Antoine "hashar" Musso (WMF) 2012-03-27 19:51:15 UTC
Setting the charset to utf-8 can cause some trouble with key length according to upstream author : http://groups.google.com/group/repo-discuss/msg/b9584ce01b4e4812 though he is speaking about utf-24 (or is it utf-32?).

Anyway, we might only want to the utf-8 to be on some specific fields and tables.

Recommendation is to use either the embed H2 database or postgreSQL.
Comment 3 Sam Reed (reedy) 2012-03-27 19:52:12 UTC
*** Bug 35536 has been marked as a duplicate of this bug. ***
Comment 4 Mark A. Hershberger 2012-03-29 20:48:21 UTC
Chad thinks he can adjust the collation without an issue.  He'll test
his theory.
Comment 5 Chad H. 2012-04-12 19:30:47 UTC
Duping to the other bug, it's got more information.

*** This bug has been marked as a duplicate of bug 35626 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links