Last modified: 2014-03-07 19:05:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 62351 - MobileFrontend doesn't correctly handle LTR content in RTL contexts
MobileFrontend doesn't correctly handle LTR content in RTL contexts
Status: RESOLVED DUPLICATE of bug 61258
Product: MobileFrontend
Classification: Unclassified
stable (Other open bugs)
unspecified
All All
: Unprioritized normal
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2014-03-06 23:53 UTC by Ryan Kaldari
Modified: 2014-03-07 19:05 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ryan Kaldari 2014-03-06 23:53:39 UTC
Compare:
https://en.wikipedia.org/wiki/Paper_clip?uselang=he
https://en.m.wikipedia.org/wiki/Paper_clip?uselang=he&mobileaction=beta

On desktop, the content div specifies the text direction based on the content language:
<div id="mw-content-text" class="mw-content-ltr" lang="en" dir="ltr">

On mobile, we don't:
<div id="content" class="content">

The first step to fixing this is to add dir="xxx" to the content div. That will fix the text alignment and punctuation. We may also want to change how we handle aligning images and TOC to match desktop as well (but see Bug 62349).
Comment 1 Jon 2014-03-07 00:23:43 UTC
Isn't this bug 61258 ?
Comment 2 Bingle 2014-03-07 17:51:05 UTC
Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1752
Comment 3 Jon 2014-03-07 19:05:59 UTC
See http://en.m.wikipedia.beta.wmflabs.org/wiki/Forty-seven_Ronin?uselang=he

*** This bug has been marked as a duplicate of bug 61258 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links