Last modified: 2014-03-07 19:05:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 62349 - Images in rtl (hebrew .. .etc) should be aligned to the left
Images in rtl (hebrew .. .etc) should be aligned to the left
Status: RESOLVED DUPLICATE of bug 61258
Product: MobileFrontend
Classification: Unclassified
alpha (Other open bugs)
unspecified
All All
: Unprioritized normal
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2014-03-06 23:01 UTC by Haitham
Modified: 2014-03-07 19:05 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Haitham 2014-03-06 23:01:10 UTC
basically rtl & ltr pages should look mirrored.
Comment 1 Ryan Kaldari 2014-03-06 23:37:35 UTC
I'm confused. In Mobile the images are mirrored, but on desktop they are not. Compare:

https://en.wikipedia.org/wiki/Paper_clip?uselang=he

https://en.m.wikipedia.org/wiki/Paper_clip?uselang=he&mobileaction=beta

Should this bug be filed under core instead?

There is a separate issue of content that is aligned with inline styles (such as infoboxes, navboxes, and other templates). Unfortunately, we have no control over these as their alignment is set by whoever creates the templates on-wiki. There might be some way to switch them on the client-side, but this would cause the page to change dramatically after it first renders.

It also looks like there are some issues with text alignment for ltr text in rtl pages.
Comment 2 Bingle 2014-03-07 17:50:56 UTC
Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1751
Comment 3 Jon 2014-03-07 19:05:42 UTC
See http://en.m.wikipedia.beta.wmflabs.org/wiki/Forty-seven_Ronin?uselang=he

*** This bug has been marked as a duplicate of bug 61258 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links