Last modified: 2014-03-07 19:05:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 61258 - UI language code and direction are applied to content in MobileFrontend
UI language code and direction are applied to content in MobileFrontend
Status: RESOLVED FIXED
Product: MobileFrontend
Classification: Unclassified
stable (Other open bugs)
unspecified
All All
: Unprioritized normal
: ---
Assigned To: Nobody - You can work on this!
:
: 62349 62351 (view as bug list)
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2014-02-12 09:31 UTC by Amir E. Aharoni
Modified: 2014-03-07 19:05 UTC (History)
12 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2014-02-12 09:31:19 UTC
In desktop MediaWiki there's a clear separation between user interface language and content language. They can be different. For example, in Commons the content language is English, but many people browse it in other languages.

This is not done in MobileFrontend. This is especially apparent if the direction (ltr/rtl) of the user language is different from the content language.

To see the problem do this:

1. Log in to http://meta.wikimedia.org .
2. Go to preferences and change your language to Hebrew.
3. Go to https://meta.m.wikimedia.org/wiki/Wikimedia_Forum .

Expected: The content of the page is supposed to be set to left-to-right direction.
Observed: The content of the page is right-to-left.

The attributes lang="he" dir="rtl" from <html> are applied to the whole page.

<div id="content"> should probably have lang="en" dir="ltr" (or whatever is needed according to the site's content language).
Comment 1 Bingle 2014-02-14 17:53:13 UTC
Prioritization and scheduling of this bug is tracked on Mingle card https://wikimedia.mingle.thoughtworks.com/projects/mobile/cards/1700
Comment 2 Gerrit Notification Bot 2014-03-03 20:42:34 UTC
Change 116538 had a related patch set uploaded by MaxSem:
Display content in its intended directionality

https://gerrit.wikimedia.org/r/116538
Comment 3 Gerrit Notification Bot 2014-03-03 22:34:29 UTC
Change 116538 merged by jenkins-bot:
Display content in its intended directionality

https://gerrit.wikimedia.org/r/116538
Comment 4 Jon 2014-03-07 19:05:42 UTC
*** Bug 62349 has been marked as a duplicate of this bug. ***
Comment 5 Jon 2014-03-07 19:05:59 UTC
*** Bug 62351 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links