Last modified: 2014-04-17 19:46:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 63942 - Remove font choices from REL1_23 branch while the implementation is unstable
Remove font choices from REL1_23 branch while the implementation is unstable
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.23.0
All All
: High normal (vote)
: 1.23.0 release
Assigned To: Nobody - You can work on this!
:
Depends on: 63817 63827 63844
Blocks: typography-refresh
  Show dependency treegraph
 
Reported: 2014-04-15 14:36 UTC by Quim Gil
Modified: 2014-04-17 19:46 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---
federicoleva: Backport_to_Stable+


Attachments

Description Quim Gil 2014-04-15 14:36:02 UTC
REL1_23 has been branched, and MediaWiki 1.23.0 is expected to be released by the end of May.

http://git.wikimedia.org/log/mediawiki%2Fcore.git/refs%2Fheads%2FREL1_23
http://lists.wikimedia.org/pipermail/wikitech-l/2014-April/076002.html

It contains

[mediawiki/core.git] / skins / vector / variables.less
@content-heading-font-family: "Linux Libertine", Georgia, Times, serif;

Please consider reverting in REL1_23 the font choices for headers applied to the MediaWiki master branch the past weeks. They are known to cause problems and unintended behavior in Chinese / Japanese / Korean, and perhaps other non-Latin scripts. The work to define font choices for MediaWiki is ongoing, and currently it is too unstable and risky to be pushed in an official MediaWiki release.

Once the implementation is settled in the master branch, it can be pushed to the corresponding MediaWiki release.
Comment 1 Bartosz Dziewoński 2014-04-15 19:37:34 UTC
This sounds like a very reasonable thing to do to avoid i18n support regression, especially since 1.23 will be a long-term support release.
Comment 2 Steven Walling 2014-04-15 21:17:04 UTC
Per bug 63817 any serif whatsoever will cause some issues for Japanese-speaking users on older versions of IE. That is practically speaking the worst issue; other complaints are more stylistic (e.g. old style numerals feeling weird in CJK, which does not normally have such a style). https://gerrit.wikimedia.org/r/#/c/125760/ should allow us to have our cake and eat it too by providing alternative style declarations for CJK. In the meantime, removing them from the general MediaWiki release seems fine to me, provided this will not impact what is deployed on wmf sites.
Comment 3 Gerrit Notification Bot 2014-04-17 19:37:31 UTC
Change 127132 had a related patch set uploaded by Nemo bis:
Remove font choices from REL1_23 branch while the implementation is unstable

https://gerrit.wikimedia.org/r/127132
Comment 4 Gerrit Notification Bot 2014-04-17 19:45:46 UTC
Change 127132 merged by jenkins-bot:
Remove font choices from REL1_23 branch while the implementation is unstable

https://gerrit.wikimedia.org/r/127132
Comment 5 Bartosz Dziewoński 2014-04-17 19:46:54 UTC
Done, for 1.23 release branch only.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links