Last modified: 2014-11-17 09:21:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 63351 - Document "Typography refresh/update" CSS changes for Vector
Document "Typography refresh/update" CSS changes for Vector
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.23.0
All All
: Highest major with 1 vote (vote)
: 1.23.0 release
Assigned To: Nobody - You can work on this!
: code-update-regression
Depends on: 65390
Blocks: documentation typography-refresh
  Show dependency treegraph
 
Reported: 2014-04-01 07:31 UTC by Nemo
Modified: 2014-11-17 09:21 UTC (History)
13 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nemo 2014-04-01 07:31:13 UTC
Ic5ba836364d04b2c3814777b69b5f47fce25292a , as noted in <http://lists.wikimedia.org/pipermail/wikitech-l/2014-March/075498.html>, introduced extensive CSS changes, but has no release notes, in total disregard of [[mw:Manual:Coding conventions]]. Unless fixed, the change is liable to immediate revert; at any rate, it can't land in a stable release as is.

We need release notes explaining:
1) what changed exactly,
2) why,
3) how a wiki can be configured to keep the 1.22 styles.
Once done, though it's not on the "coding" mandatory part,
4) MediaWiki users need to be notified on mediawiki-l,
5) [[mw:MediaWiki 1.23]] needs to be updated.

Point (1) can perhaps be achieved by distilling the content of [[mw:Typography refresh]], while for (2) we're currently in total lack of rationales (cf. <https://www.mediawiki.org/?oldid=945913#Wikipedia_or_MediaWiki.3F>) and on (3) I've not heard anything.

On (4), the extensive usage of Wikimedia-only discussion venues, for months, gave the definite impression that this change was planned for Wikimedia projects only, so (unless the change is reverted in core) an energic communication will be needed to compensate and properly notify/involve MediaWiki users.
Comment 1 Bartosz Dziewoński 2014-04-01 07:47:26 UTC
A (very brief) release notes entry was already added in Ic9dc071d. It definitely could use improvement, though.
Comment 2 Nemo 2014-04-01 11:24:51 UTC
Reset priority: release notes by definition must be in next release.
Comment 3 Andre Klapper 2014-04-01 16:06:01 UTC
That "next release" is 1.23 and three (?) weeks away. Leaving it up to the corresponding developers to judge how fast this will get handled...
Comment 4 Nemo 2014-04-11 07:17:18 UTC
(In reply to Andre Klapper from comment #3)
> That "next release" is 1.23 and three (?) weeks away. Leaving it up to the
> corresponding developers to judge how fast this will get handled...

For now there seems to be consensus that – absent documented, stable decisions on fonts (and the rest?) – the 1.22 status quo should be kept in 1.23.
http://lists.wikimedia.org/pipermail/wikitech-l/2014-April/075907.html
Comment 5 Steven Walling 2014-04-11 07:40:06 UTC
(In reply to Nemo from comment #4)
> (In reply to Andre Klapper from comment #3)
> > That "next release" is 1.23 and three (?) weeks away. Leaving it up to the
> > corresponding developers to judge how fast this will get handled...
> 
> For now there seems to be consensus that – absent documented, stable
> decisions on fonts (and the rest?) – the 1.22 status quo should be kept in
> 1.23.
> http://lists.wikimedia.org/pipermail/wikitech-l/2014-April/075907.html

You link to one user stating their personal preference, and call it consensus?
Comment 6 Nemo 2014-04-11 07:48:43 UTC
(In reply to Steven Walling from comment #5)
> You link to one user stating their personal preference, and call it
> consensus?

Nobody objected so far.
Comment 7 Bartosz Dziewoński 2014-04-17 19:46:29 UTC
As of I595feec9, the MediaWiki 1.23 release branch does not include any fonts changes compared to previous releases – everything, text and headings, is just 'sans-serif'.

Someone still needs to document all the other changes to text style.
Comment 8 Erwin Dokter 2014-04-30 12:41:45 UTC
I don't know where you want them or how detaild they should be, but here are the core changes (that I know of)...

* Various Vector CSS properties have been converted to LESS variables
* The font size of #bodyContent/.mw-body-content has been increased to 0.875em
* The line-height of #bodyContent/.mw-body-content has been increased to 1.6
* All headers have updated sizes and margins
* H1 and H2 headers now use a serif font

For now, the body font has been reverted to just sans-serif.
Comment 9 Mark A. Hershberger 2014-05-09 16:03:43 UTC
I've copied Erwin's comments to https://www.mediawiki.org/wiki/MediaWiki_1.23#CSS_Refresh_for_Vector and will point to that section in the release notes.
Comment 10 Mark A. Hershberger 2014-05-09 16:14:09 UTC
Since the release notes already point to Typography update, I think URL currently in RELEASE-NOTES-1.23 in master + the on-wiki information I just added is sufficient.  We'll sync them up before release.
Comment 11 Nemo 2014-05-16 10:26:55 UTC
I don't see anything in RELEASE-NOTES-1.23, branch or master.
Comment 12 Andre Klapper 2014-05-16 11:12:53 UTC
(In reply to Nemo from comment #11)
> I don't see anything in RELEASE-NOTES-1.23, branch or master.

https://git.wikimedia.org/blob/mediawiki%2Fcore.git/20c2b9e4cee296fa1caa1cdcae37d6e883067519/RELEASE-NOTES-1.23#L150  not specific enough?
Comment 13 Nemo 2014-05-16 11:24:23 UTC
(In reply to Andre Klapper from comment #12)
> not
> specific enough?

See comment 0 and 1.
Comment 14 Quiddity 2014-05-16 19:03:50 UTC
Someone who knows the /exact/ changes, needs to go through
https://www.mediawiki.org/wiki/MediaWiki_1.23#CSS_refresh_for_Vector
and
https://www.mediawiki.org/wiki/Typography_refresh
to update the things that were changed since those docs were written, and add any missing items. 
(eg. The FAQ Summary says "The superscript (sup) and subscript (sub) line-heights are now set to 1" but I think that was changed to "0" at some point? and it's not mentioned in the [MediaWiki_1.23] page.

Possibly there are more links that should be added to this list?
https://www.mediawiki.org/wiki/Typography_refresh#Code_links

We want/need details and specifics.
Comment 15 Erwin Dokter 2014-05-16 23:07:58 UTC
I've made some updates to those pages.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links