Last modified: 2014-05-05 10:07:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 55779 - Personal links and tabs are reversed in the Vector skin
Personal links and tabs are reversed in the Vector skin
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Highest blocker (vote)
: ---
Assigned To: Jon
: i18n
Depends on:
Blocks: rtl wmf-deployment 55629
  Show dependency treegraph
 
Reported: 2013-10-16 09:26 UTC by Amir E. Aharoni
Modified: 2014-05-05 10:07 UTC (History)
14 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Incorrect rendering as of 08cf0b1395 (lang=he) (50.48 KB, image/png)
2013-10-16 10:47 UTC, Bartosz Dziewoński
Details
Correct rendering as of 08cf0b1395^ (lang=he) (50.72 KB, image/png)
2013-10-16 10:47 UTC, Bartosz Dziewoński
Details

Description Amir E. Aharoni 2013-10-16 09:26:12 UTC
The personal links and the page tabs (Page, Talk etc.) are reversed in the Vector skin when the UI language is RTL. This is a recent regression. It is already deployed in Commons. Example: https://commons.wikimedia.org/wiki/Main_Page?uselang=he .
Comment 1 Amir E. Aharoni 2013-10-16 09:40:05 UTC
It was probably introduced in https://gerrit.wikimedia.org/r/#/c/85920/ .
Comment 2 Bartosz Dziewoński 2013-10-16 09:51:45 UTC
Related (and probably the root cause for this mess): bug 46947.
Comment 3 Siebrand Mazeland 2013-10-16 10:01:58 UTC
Adding release manager and person doing most deployments. LangEng advises to NOT deploy further.
Comment 4 Antoine "hashar" Musso (WMF) 2013-10-16 10:37:27 UTC
Can you please confirm that https://gerrit.wikimedia.org/r/#/c/85920/ is indeed causing the issue?  One could test out by checking out the previous commit (08cf0b1395^) look at the page, then check the commit ( 08cf0b1395 ) and look at the page.

Screenshots of each steps highlighting the issue would be nice as well. Most people are confused with expected rendering on RTL wiki (including me).
Comment 5 Bartosz Dziewoński 2013-10-16 10:40:10 UTC
You can look at attachments to bug 55629 (the first and the second one).
Comment 6 Bartosz Dziewoński 2013-10-16 10:44:59 UTC
Verified, 08cf0b1395 is indeed the culprit.
Comment 7 Bartosz Dziewoński 2013-10-16 10:47:26 UTC
Created attachment 13503 [details]
Incorrect rendering as of 08cf0b1395 (lang=he)
Comment 8 Bartosz Dziewoński 2013-10-16 10:47:46 UTC
Created attachment 13504 [details]
Correct rendering as of 08cf0b1395^ (lang=he)
Comment 10 Kevin Israel (PleaseStand) 2013-10-16 14:09:43 UTC
I suspect this is because of how lessphp handles comments such as /* @noflip */ when they come before the selector. All comments outside the braces get moved to before all the CSS rules.
Comment 11 Gerrit Notification Bot 2013-10-16 15:13:24 UTC
Change 90133 had a related patch set uploaded by Jdlrobson:
Move noflip annotations into rules themselves

https://gerrit.wikimedia.org/r/90133
Comment 12 Jon 2013-10-16 15:14:30 UTC
Can someone verify the above patch has the desired effect? It was indeed the noflip annotations. I've moved them next to the rules they flip...
Comment 13 Bartosz Dziewoński 2013-10-16 17:26:58 UTC
Bug 54673, which is the second underlying issue here ;) ("LESS compiler should preserve the position of CSSMin / CSSJanus annotations") has been reopened.
Comment 14 Gerrit Notification Bot 2013-10-16 17:29:02 UTC
Change 90133 merged by jenkins-bot:
Move noflip annotations into rules themselves

https://gerrit.wikimedia.org/r/90133
Comment 15 Bartosz Dziewoński 2013-10-16 17:30:08 UTC
Worked around.

Also, while the fix is a workaround, I think it's also a genuine improvement of the code in general (explicit is better than implicit), so personally I don't feel bad about merging it. :)
Comment 16 Gerrit Notification Bot 2013-10-16 17:35:52 UTC
Change 90169 had a related patch set uploaded by Bartosz Dziewoński:
Move noflip annotations into rules themselves

https://gerrit.wikimedia.org/r/90169
Comment 17 Gerrit Notification Bot 2013-10-16 17:41:43 UTC
Change 90169 merged by jenkins-bot:
Move noflip annotations into rules themselves

https://gerrit.wikimedia.org/r/90169
Comment 18 Bartosz Dziewoński 2014-05-05 10:00:24 UTC
To summarize:

This works correctly, if there is only one instance of each property in the block (a property might be repeated several times for browser hacks, see bug 61941):

    .class {
        /* @noflip */
        margin-left: 1em;
        /* @noflip */
        margin-right: 2em;
    }

This doesn't generally work, although sometimes it does due to pure chance:

    /* @noflip */
    .class {
        margin-left: 1em;
        margin-right: 2em;
    }
Comment 19 Bartosz Dziewoński 2014-05-05 10:07:20 UTC
(I meant to post this on bug 54673, sorry.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links