Last modified: 2014-09-13 17:13:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 44420 - Restore interwiki (sister projects) results in search queries
Restore interwiki (sister projects) results in search queries
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CirrusSearch (Other open bugs)
master
All All
: High enhancement with 2 votes (vote)
: ---
Assigned To: Chad H.
:
: 25278 (view as bug list)
Depends on:
Blocks: 24767 63629 19020 20375
  Show dependency treegraph
 
Reported: 2013-01-28 10:08 UTC by Nemo
Modified: 2014-09-13 17:13 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nemo 2013-01-28 10:08:38 UTC
For a short while, Special:Search showed results from other wikis in a very sensible way: for instance, looking for a word on Wikipedia gave you also a link to the entry on Wiktionary in the same language; searching for a name gave also the link to the person's quotations on Wikiquote; etc. If I remember correctly, they were displayed in a box on the right side of the screen.

This is a feature that, from what I recall, had a universally and greatly positive reaction and then suddenly disappeared. It's quite obviously useful because few readers (or even editors) know the differences between Wikipedia, Wiktionary, Wikiquote, Wikinews... We've missed it for many years now and it should probably be among the highest priority feature requests for our search (after "keep search lights on" but before any design or user experience work).

I don't remember any detail, maybe someone can find links. Looks like it was around 2009.
Comment 1 Nemo 2013-02-22 05:39:31 UTC
See also bug 16283 comment 10 for something this may help fixing (or not).
Comment 2 Nemo 2013-05-24 19:29:45 UTC
btw

(Ram on bug 47775 comment #5)
> The current search code (Java) already has a mode for "interwiki" searches
> but
> it is currently disabled
Comment 3 Krinkle 2013-07-28 21:16:55 UTC

*** This bug has been marked as a duplicate of bug 21685 ***
Comment 4 Nemo 2013-08-05 15:21:48 UTC
Updating priority as, according to the RfC, this is indeed one of the key things in consideration for the new search system.
Comment 5 Andre Klapper 2013-08-06 12:14:32 UTC
(In reply to comment #4)
> Updating priority as, according to the RfC, this is indeed one of the key
> things in consideration for the new search system.

Which RfC?
Comment 6 Nemo 2013-08-06 12:36:22 UTC
(In reply to comment #5)
> Which RfC?

https://www.mediawiki.org/w/index.php?title=Talk:Requests_for_comment/CirrusSearch&diff=716862&oldid=716855
Of course it won't be the first release(s) but "I like the idea a lot" to me means that we/they want to keep an eye on this request, hence the priority to avoid losing it.
Comment 7 Nik Everett 2013-09-04 14:52:19 UTC
Yeah - it is reasonably high priority to me.  Especially with regards to Bug 53531 which is a limited form of interwiki search that we do still have on in the old search code.
Comment 8 Nemo 2013-11-06 18:26:22 UTC
Magnus has written a script which adds Wikidata search results: http://blog.magnusmanske.de/?p=108
http://magnusmanske.de/wordpress/wp-content/uploads/2013/11/wdsearch.png
This mostly helps with inter-language searches (for title and? something more) in the same project, despite being technically inter-project.
Comment 9 Andre Klapper 2013-11-08 12:52:48 UTC
*** Bug 25278 has been marked as a duplicate of this bug. ***
Comment 10 Gerrit Notification Bot 2014-02-06 17:53:15 UTC
Change 105986 had a related patch set uploaded by Chad:
Implement interwiki searches

https://gerrit.wikimedia.org/r/105986
Comment 11 Gerrit Notification Bot 2014-02-06 18:12:16 UTC
Change 105986 merged by jenkins-bot:
Implement interwiki searches

https://gerrit.wikimedia.org/r/105986
Comment 12 Chad H. 2014-02-13 06:11:34 UTC
Marking this fixed because it's basically implemented. We can always tidy things up later (and we will).
Comment 13 Amgine 2014-02-13 16:15:15 UTC
Talking to #Wikidata, only Wikipedia, Commons, Wikisource, and Wikivoyage are interwikied in any way. For Wiktionary, Wikinews, Wikibooks, Wikiquote, Wikiversity, Wikispecies, and Incubator this is still broken.
Comment 14 Nemo 2014-02-13 16:25:13 UTC
(In reply to Amgine from comment #13)
> Talking to #Wikidata, only Wikipedia, Commons, Wikisource, and Wikivoyage
> are interwikied in any way. For Wiktionary, Wikinews, Wikibooks, Wikiquote,
> Wikiversity, Wikispecies, and Incubator this is still broken.

I don't understand this comment, as far as I know this is not related to Wikidata in any way.
Comment 15 Amgine 2014-02-13 16:44:43 UTC
(In reply to Nemo from comment #14)
> (In reply to Amgine from comment #13)
> > Talking to #Wikidata, only Wikipedia, Commons, Wikisource, and Wikivoyage
> > are interwikied in any way. For Wiktionary, Wikinews, Wikibooks, Wikiquote,
> > Wikiversity, Wikispecies, and Incubator this is still broken.
> 
> I don't understand this comment, as far as I know this is not related to
> Wikidata in any way.

The patch searches the Wikidata Interwikis only.
Comment 16 Chad H. 2014-02-13 16:51:12 UTC
(In reply to Amgine from comment #15)
> (In reply to Nemo from comment #14)
> > (In reply to Amgine from comment #13)
> > > Talking to #Wikidata, only Wikipedia, Commons, Wikisource, and Wikivoyage
> > > are interwikied in any way. For Wiktionary, Wikinews, Wikibooks, Wikiquote,
> > > Wikiversity, Wikispecies, and Incubator this is still broken.
> > 
> > I don't understand this comment, as far as I know this is not related to
> > Wikidata in any way.
> 
> The patch searches the Wikidata Interwikis only.

What do you mean by that? The search doesn't care about the interwiki prefix really, it's what's returned. I think core Special:Search and/or wikidata are mishandling the prefixes actually, not Cirrus.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links