Last modified: 2014-06-03 21:49:52 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20375 - Interwiki search use canonical namespace name
Interwiki search use canonical namespace name
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CirrusSearch (Other open bugs)
master
All All
: High normal (vote)
: ---
Assigned To: Chad H.
http://en.wikipedia.beta.wmflabs.org/...
:
: 21717 (view as bug list)
Depends on: 44420
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-24 13:42 UTC by Platonides
Modified: 2014-06-03 21:49 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Platonides 2009-08-24 13:42:01 UTC
An interwiki search which return results on another project which are not in the main namespace, use the canonical namespace, which is wrong for that language. So in the URL it should have 'Ayuda' instead of 'Help'.
Note that since groups are joined by language, it could use the local translation for that namespace, except for NS_PROJECT (NS_PROJECT_TALK). The value of wgMetaNamespace would need to be fetched from SiteConf.

Results from extra namespaces don't present this issue, they have the right namespace name.


Related to bug 15452 ?
Comment 1 Bugmeister Bot 2011-08-19 19:12:41 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 2 Nemo 2013-01-17 17:06:59 UTC
(In reply to comment #0)
> An interwiki search which return results on another project [...]

Platonides, I don't remember, wasn't this feature removed completely? (And is there a bug somewhere to restore it? It's one of the features I liked most in MediaWiki's history.)
Comment 3 Platonides 2013-01-28 09:56:52 UTC
Yes, it was removed at some point. Although this bug shows that it was active in 2009. Feel free to open a bug to restore it, blocking on this bug.
Comment 4 Nemo 2013-04-28 08:59:23 UTC
*** Bug 21717 has been marked as a duplicate of this bug. ***
Comment 5 Nemo 2013-04-28 08:59:50 UTC
See attachment 6850 [details].
Comment 6 Dan Garry 2014-02-10 22:16:41 UTC
Interwiki search no longer exists in Lucene, and interwiki search in Cirrus will look nothing like it looks in Lucene. Therefore, in the present day, this bug is RESOLVED INVALID.
Comment 7 Nemo 2014-02-10 22:24:51 UTC
Actually, the very example provided in comment 0 proves this bug is valid for Cirrus too (though I wouldn't call it a severe bug).
Comment 8 Nik Everett 2014-02-10 22:51:40 UTC
That link certainly doesn't spit out a nice looking page:
en.wikivoyage.org results:
    wikivoyage:Project:LanguageEs.php

Yikes!

This one doesn't look great either:
http://en.wikipedia.beta.wmflabs.org/w/index.php?title=Special%3ASearch&profile=advanced&search=main&fulltext=Search&ns0=1&ns1=1&ns2=1&ns3=1&ns4=1&ns5=1&ns6=1&ns7=1&ns8=1&ns9=1&ns10=1&ns11=1&ns12=1&ns13=1&ns14=1&ns15=1&profile=advanced
en.wikivoyage.org results:
    wikivoyage:Main Page
    wikivoyage:Talk:Main Page
    wikivoyage:User talk:Peterfitzgerald
    wikivoyage:Project:Main Page guidelines
(more)
en.wikinews.org results:
    wikinews:Main Page
(more)
en.wikivoyage.org results:
    wikivoyage:Disneyland
    wikivoyage:Kruger National Park
    wikivoyage:Indonesia
    wikivoyage:Moscow

These are all ugly, but don't show the language problem.  I can't reproduce the language issue but wouldn't be surprised about it.  Say you search on de.wikipedia.org.  You want the namespaces to come back translated properly into German regardless of what the actual wiki's language is in.
Comment 9 Chad H. 2014-02-13 04:34:59 UTC
This is sort of being worked on as a result of other things.
Comment 10 Chad H. 2014-03-13 20:11:11 UTC
I think this is better as of today. We should configure it on beta for more languages and test.
Comment 11 Chad H. 2014-06-03 21:49:52 UTC
I'm pretty sure this is better now. If we can find any examples in Cirrus where it's wrong feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links