Last modified: 2008-12-28 22:00:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 42 - can't search for numbers (no numerical search)
can't search for numbers (no numerical search)
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://sourceforge.net/tracker/index....
:
: 9405 (view as bug list)
Depends on: 7726
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-14 10:51 UTC by Antoine "hashar" Musso (WMF)
Modified: 2008-12-28 22:00 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Antoine "hashar" Musso (WMF) 2004-08-14 10:51:33 UTC
FEATURE REQUEST MIGRATED FROM SOURCEFORGE:

Submitted By: Koyaanis Qatsi - koyaanisqatsi
Date Submitted: 2002-06-12 20:37

 The search function has generally improved, but it
could improve even more, I think:

searching for "circle of confusion" yields no results.
if there are no results because of "of", maybe the
search should ignore the word and match results on
remaining terms. then it would have found what "circle
confusion" found, i.e. [[depth of field]]. (people are
used to google, which drops common words automatically)

some useful words have only two letters. e.g. "pi".

no raw numerical search turns up results. e.g.
"3.1428" or "8 1/2". I doubt that will be crucial, but
it would be nice to have the option.


Date: 2003-08-04 03:38
Sender: nobody
Logged In: NO 

Oh man, don't scare me.  First thing I thought when I saw
this bug title was that the Feds were after people's search
terms and browsing history.  Maybe some privacy features
should be added to make sure that data isn't kept around.




Date: 2003-09-08 20:01
Sender: myreddice
Logged In: YES 
user_id=861973

http://www.wikipedia.org/w/wiki.phtml?
search=circle+of+confusion

http://www.wikipedia.org/w/wiki.phtml?search=%
22circle+of+confusion%22

There are some results now. Pi is still an issue, though

Date: 2003-12-10 11:08
Sender: hashar
Logged In: YES 
user_id=663115

Seems the feature is implemented now.

Only thing missing:  searching for 3.14 or "3.14" or
"3.1415"
doen't found pi.
Comment 1 Chris Wood 2004-08-23 08:14:35 UTC
Changed summary to reflect new half-fixed status.
Comment 2 Jamesday 2004-11-19 22:38:30 UTC
See this bug, which if implemented as suggested will break the ability to search
for pi with "3.14": http://bugzilla.wikimedia.org/show_bug.cgi?id=375
Comment 3 Horcrux 2005-08-28 00:28:34 UTC
Created attachment 833
Comment 4 Brion Vibber 2007-03-26 13:41:15 UTC
*** Bug 9405 has been marked as a duplicate of this bug. ***
Comment 5 Brion Vibber 2008-08-18 17:51:51 UTC
*** Bug 15229 has been marked as a duplicate of this bug. ***
Comment 6 Brion Vibber 2008-08-18 17:55:16 UTC
Here's an oldie but goodie... :)

This may be an issue with MySQL's stopword system; or it might simply be the default word length limit -- by default up to 3-charater words will be ignored. Or it might be ignoring numbers just for fun...

This definitely deserves some experimentation and workarounds if necessary; reasonable behavior of the search engine on a default install would be very nice.
Comment 7 Reed Hedges 2008-08-18 18:17:18 UTC
You mean this bug is *FOUR* years old???

Here's my "duplicate" bug report:

I couldn't find anything about this in the MediaWiki manual, or in Bugzilla, in
the Release Notes for 1.13, or in Google:

If I include a number (a numeral) in a search query, or a word that starts with
a number, I always get 0 results, even though I know I have pages that have
that number in them.  For example, if I have a wiki page about 64-bit PC
architecture, I can search for "bit" and "pc" and "bit pc" and "pc bit" and see
the page in the results, but if I search for "64 bit" or "64bit" or "64bit PC"
or "64 bit architecture" or "pc 64 bit architecture" I always get 0 results.  

Comment 8 Reed Hedges 2008-08-18 18:19:14 UTC
Note that it's not a word size issue, since I can find "PC" but not "64". Also I'm using Postgresql not mySQL.

Wikipedia doesn't have this problem, do they have a different search engine?
Comment 9 Brion Vibber 2008-08-20 17:24:47 UTC
I've un-duped bug 15229 as PostgreSQL uses a different search backend from the MySQL default.

(Wikipedia also uses a different search engine.)
Comment 10 Reed Hedges 2008-08-20 17:58:23 UTC
Looks like WP uses Extension:MWSearch and Lucene right?  So that would be a workaround for this bug and bug 15229?  Are there any other search engines available other than Lucene and the basic SQL search?
Comment 11 Brion Vibber 2008-12-28 22:00:02 UTC
Fix for bug 7726 takes care of this for the default MySQL backend. (Will be in 1.14.)

Bug 15229 presumably remains for PostgreSQL.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links