Last modified: 2012-04-16 09:16:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27485 - block log entry duration message is broken in RTL wikis
block log entry duration message is broken in RTL wikis
Status: RESOLVED DUPLICATE of bug 25839
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2011-02-17 03:24 UTC by Huji
Modified: 2012-04-16 09:16 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Huji 2011-02-17 03:24:31 UTC
I recently noted that on RTL Wikipedia (such as Persian Wikipedia and Arabic Wikipedia), the "duration" message for block log entries is rotated and the order of words is not correct.

Example:

http://fa.wikipedia.org/w/index.php?title=%D9%88%DB%8C%DA%98%D9%87%3A%D8%B3%DB%8C%D8%A7%D9%87%D9%87%E2%80%8C%D9%87%D8%A7&type=block&user=Behzad.Modares&page=%DA%A9%D8%A7%D8%B1%D8%A8%D8%B1%3A94.182.71.175&year=&month=-1&tagfilter=

It reads:

Behzad.Modares (بحث | مشارکت‌ها | بسته شود) «94.182.71.175 (بحث)» را ۱ روز بست 

However, instead of reading as "1 days" (in Persian) it is read as "days 1". This is because in the HTML code, the duration is surrounded by an HTML tag:

<span class="blockExpiry" dir="ltr" title="1 day">

Which has the dir value hardcoded. This breaks RTL layout and should be reverted. Such modifications should always take place at CSS level.
Comment 1 Niklas Laxström 2011-02-17 09:07:20 UTC
That's because you yourself requested it in bug 25839.
Comment 2 Huji 2011-02-17 13:30:31 UTC
Well, I never asked this to be added hardcoded; I asked this to be added through CSS.

Also, I relied on Roan's comment there, that after this change the Arabic text for "1 week" was still shown in the correct order (I didn't check it myself).

The LTR rendering is still required when the block expiry is a timestamp. However, if the expiry is a localized text, it shouldn't be rendered as LTR.
Comment 3 Mark A. Hershberger 2011-02-17 19:17:15 UTC
Resolving dupe of 25839 so that we can all concentrate on that bug.

*** This bug has been marked as a duplicate of bug 25839 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links