Last modified: 2012-04-16 09:16:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 25839 - Block end timestamp should use the right direction in logs
Block end timestamp should use the right direction in logs
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: easy
: 27485 (view as bug list)
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2010-11-08 14:48 UTC by Huji
Modified: 2012-04-16 09:16 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Huji 2010-11-08 14:48:57 UTC
Please look at the following two examples:

http://fa.wikipedia.org/w/index.php?title=%D9%88%DB%8C%DA%98%D9%87%3A%D8%B3%DB%8C%D8%A7%D9%87%D9%87%E2%80%8C%D9%87%D8%A7&type=block&user=Behzad.Modares&page=%DA%A9%D8%A7%D8%B1%D8%A8%D8%B1%3AKomeil+4life&year=&month=-1&tagfilter=

http://ar.wikipedia.org/w/index.php?title=%D8%AE%D8%A7%D8%B5%3A%D8%B3%D8%AC%D9%84&type=block&user=%D8%BA%D9%84%D8%A7%D9%85+%D8%A7%D9%84%D8%A3%D8%B3%D9%85%D8%B1&page=%D9%85%D8%B3%D8%AA%D8%AE%D8%AF%D9%85%3A212.118.5.66&year=&month=-1&tagfilter=

In both cases, the ending time of a block is changed, but because of the right-to-left layout of the wiki, the ending time is shown in an unreadable fashion. The solution would be as simple as applying a "direction:ltr" style to the <span> element which holds the new block expiration time. However, at the moment the span element doesn't have a class attribute; for example, in the first example above, the <span> looks like this:

<span title="2010-11-30T05:16:29Z">2010-11-30T05:16:29Z</span>

Solution would be to make it like this:

<span class="blockExpiry" title="2010-11-30T05:16:29Z">2010-11-30T05:16:29Z</span>

And to add the following to the default RTL CSS file:

.blockExpiry {
  direction:ltr;
}
Comment 1 Roan Kattouw 2010-11-08 15:25:55 UTC
Fixed in r76309, by adding both the class and dir="ltr" because the suggested CSS didn't work (presumably due to dir="rtl" on an ancestor <div>).

It seems very strange to set dir="ltr" on a span that may contain RTL text, and I expected it to mess up the Arabic text for "1 week", but it didn't. If it turns out this does cause something else to display wrongly, the fix for this bug should be reverted.
Comment 2 Huji 2011-02-17 13:31:49 UTC
It seems the solution is not complete, per bug 27485. The LTR rendering should be limited to the cases where the expiry is a timestamp.
Comment 3 Mark A. Hershberger 2011-02-17 19:17:15 UTC
*** Bug 27485 has been marked as a duplicate of this bug. ***
Comment 4 Huji 2011-02-18 00:12:03 UTC
In continuation to my discussion here and in bug 27485, another possible solution can be to localize the expiration dates too. Right now, they look like 2010-11-30T05:16:29Z which is LTR-friendly only. Localizing them (so for example, the Persian message would be ۲۰۱۰-۱۱-۳۰ ساعت ۰۵:۱۶:۲۹ گرینویچ can totally solve the issue of directionality.
Comment 5 Robin Pepermans (SPQRobin) 2011-07-06 21:52:59 UTC
This is fixed in trunk (1.19) because bug 6100 is fixed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links