Last modified: 2013-03-06 14:33:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27450 - Directionality of video subtitles should match the directionality of the subtitle language
Directionality of video subtitles should match the directionality of the subt...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
TimedMediaHandler (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Michael Dale
http://commons.wikimedia.org/wiki/Fil...
: i18n
Depends on: 27699
Blocks: rtl
  Show dependency treegraph
 
Reported: 2011-02-16 12:14 UTC by Amir E. Aharoni
Modified: 2013-03-06 14:33 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
demonstration of the problem (165.47 KB, image/png)
2012-11-27 05:28 UTC, Amir E. Aharoni
Details

Description Amir E. Aharoni 2011-02-16 12:14:00 UTC
Subtitles in RTL languages appear LTR. If i try to watch a clip with Hebrew subtitles in Commons, the punctuation marks appear on the wrong end of the sentence, which means that it is actually displayed LTR. This happens both when  Hebrew and English are set as the interface language.

When it is clear that a language is RTL, it should be displayed as RTL, no matter what the interface language of the site is.
Comment 1 Amir E. Aharoni 2011-04-07 13:41:23 UTC
Changed the description: This is a problem for LTR languages, too. If my interface language in Commons is Hebrew, but for whatever reason i watch a clip with subtitles in English or Italian, the subtitles are currently shown RTL and it is wrong.

If the subtitles are an HTML element, they should always have lang="XX" dir="XXX" - lang is known according to the file name and the dir is known according to the language.

This may be a problem for Azeri, which may be written in Latin and Arabic (and maybe there are still people who write it in Cyrillic) and for several languages of India, which are written in Arabic and in LTR Indian scripts. For these languages an extended code should be used, something like az-Arab / az-Latn.
Comment 2 Michael Dale 2011-04-07 23:03:18 UTC
Thanks for the bug report. I have added it as dependency to the deploy timed media handler bug. I will put the fix on the TMH prototype soon: http://prototype.wikimedia.org/timedmedia/Main_Page
Comment 3 Amir E. Aharoni 2012-11-27 05:17:11 UTC
Same problem in TimedMediaHandler. I'm just changing the component.
Comment 4 Amir E. Aharoni 2012-11-27 05:28:18 UTC
Created attachment 11426 [details]
demonstration of the problem

Playing a movie with an RTL interface language. Notice that the full stop is on the left-hand end of the English sentence - that's because the interface language's direction is applied to the subtitles. We know that the language of the subtitles is English, so the ltr direction must be assigned explicitly.
Comment 5 Jan Gerber 2012-12-31 12:59:49 UTC
https://gerrit.wikimedia.org/r/41573 submitted for review to fix this issue.
Comment 6 Andre Klapper 2013-01-09 13:38:54 UTC
mdale:
This report has been in ASSIGNED status for more than one year and you are set as its assignee. In case that you are not actively working on a fix, please reset the bug status to NEW/UNCONFIRMED.
In case you do not plan to work on a fix in the near future: Please also edit the "Assigned To" field by clicking "Reset Assignee to default", in order to not prevent potential contributors from working on a fix. Thanks for your help!
[assigned>=1y]

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links