Last modified: 2012-11-20 13:48:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27699 - Review and deploy TimedMediaHandler extension (timed media handler) to Wikimedia wikis
Review and deploy TimedMediaHandler extension (timed media handler) to Wikime...
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Extension setup (Other open bugs)
unspecified
All All
: Normal enhancement with 2 votes (vote)
: ---
Assigned To: Michael Dale
http://prototype.wikimedia.org/timedm...
: tracking
: 7433 23888 (view as bug list)
Depends on: 27336 27641 28840 29175 29176 29177 29178 29179 29180 29181 29182 29184 29185 29291 37470 38455 40070 41528 41826
Blocks: tracking 30112 40193 24988 25269 27450 30347 30653 39869
  Show dependency treegraph
 
Reported: 2011-02-25 04:21 UTC by Michael Dale
Modified: 2012-11-20 13:48 UTC (History)
23 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Michael Dale 2011-02-25 04:21:21 UTC
A tracking bug to tag trunk dependency bugs. Timed media handler still needs to be reviewed, refined, some resource loader patches remain to be written, etc. 

A live prototype install is available at: 
http://prototype.wikimedia.org/timedmedia/Main_Page

That prototype page will reflect the most recent version of the extension. 

I include an initial patch to trunk on this bug so people can get TMH running locally.
Comment 1 Michael Dale 2011-02-25 05:30:40 UTC
*** Bug 23888 has been marked as a duplicate of this bug. ***
Comment 2 Krinkle 2011-03-25 01:40:02 UTC
Where's the patch ?
Comment 3 Michael Dale 2011-03-25 16:51:33 UTC
Krinkle its an extension not a patch. 

I am presently working through the first review pass by Roan here: http://www.mediawiki.org/wiki/User:Catrope/Extension_review/TimedMediaHandler
Comment 4 Krinkle 2011-04-07 11:48:14 UTC
(In reply to comment #3)
> (In reply to comment #2)
>> Where's the patch ?
>
> Krinkle its an extension not a patch. 
> 
> I am presently working through the first review pass by Roan here:
> http://www.mediawiki.org/wiki/User:Catrope/Extension_review/TimedMediaHandler

That much I know, I was referring to this "patch":
> I include an initial patch to trunk on this bug so people
> can get TMH running locally.

Or is that no longer needed and part of the extension ?
Comment 5 Michael Dale 2011-04-07 23:00:28 UTC
(In reply to comment #4)
> Or is that no longer needed and part of the extension ?

Yes the associated dependent patches ( 27336, 27641 ) have been applied to trunk
Comment 6 Brion Vibber 2011-05-27 22:58:39 UTC
Added the raw extension name to bug title so it's easier to find. :)
Comment 7 Siebrand Mazeland 2011-06-19 08:27:39 UTC
Changing to Wikimedia.
Comment 8 Michael Dale 2011-07-08 17:45:37 UTC
Brion did you get a chance to review the associated closed bugs that you reported? Feel free to re-open anything that is still not resolved.
Comment 9 Brion Vibber 2011-11-29 22:03:28 UTC
*** Bug 7433 has been marked as a duplicate of this bug. ***
Comment 10 MZMcBride 2012-07-05 05:01:38 UTC
What's the status of this bug?
Comment 11 Jan Kucera (Kozuch) 2012-07-20 19:02:46 UTC
(In reply to comment #10)
> What's the status of this bug?

This is a normal prodedure in Wikimedia... just do nothing... over years.
Comment 12 Sumana Harihareswara 2012-07-20 19:07:15 UTC
Argh, sorry I missed the "what's the status of this bug?" question a few weeks ago

TMH has been reviewed by Ian Baker and NeilK extensively, with lots of changes made by Michael Dale. Review notes and Michael's follow-up at https://www.mediawiki.org/wiki/TimedMediaHandler/ReviewNotes . It's currently being tested by Chris McMahon and was also tested partially by Tauhida Parveen, including transcoding support, at http://commons.wikimedia.beta.wmflabs.org/wiki/File:Electric_sheep.webm . Progress on deploying TMH is dependent on robustness of Wikimedia Labs; Labs as a robust environment, suitable for testing, is improving as Antoine Musso works on it.

CC'ing Chris and Antoine so they can possibly give further updates.
Comment 13 Sumana Harihareswara 2012-07-25 18:03:21 UTC
Jan Gerber is currently working on TMH and we should have more news next week.
Comment 14 Sumana Harihareswara 2012-08-17 20:00:10 UTC
Update from Chris McMahon: http://www.gossamer-threads.com/lists/wiki/wikitech/289186 "First, the TimedMediaHandler extension that we've been testing in the beta commons wiki for quite some time has moved off of the the beta cluster and is now being installed on test2wiki in preparation for a production deployment."

https://test2.wikipedia.org/wiki/Special:Version - yes, TMH is installed there. :-)   https://www.mediawiki.org/wiki/Extension:TimedMediaHandler/TestPlan is the test plan so you can help by using those ideas to try to break it. :-)
Comment 15 Jan Kucera (Kozuch) 2012-08-28 11:15:34 UTC
So this bug will be fixed soon? All dependencies have been cleared so far...
Comment 16 Sumana Harihareswara 2012-08-30 17:34:44 UTC
Asking Chris Steipp to mark any outstanding (or fixed) blocker issues.
Comment 17 Chris Steipp 2012-09-07 23:50:48 UTC
Sorry for the slow response. My concerns were:

* Someone needs to make sure the 3rd party pieces are updated-- Michael Dale indicated he would do that
* It would be good to deploy apparmor confining for the transcoders. I'll add a bug for that, but not a blocker, since we don't confine any of our media processing currently.
* Jan addressed my concerns about iframing, so it's no longer an issue.
Comment 18 Sumana Harihareswara 2012-09-19 14:46:35 UTC
Assigning to Michael Dale since it sounds like he's in charge of the only blocker (making sure that the 3rd party pieces are updated).  Thanks.
Comment 19 Chris Steipp 2012-09-19 20:59:05 UTC
Oh, and just to clarify: Michael updated everything in July, and said he would take on making sure they stay up to date. So, if the upstreams haven't been updated since July, then I think we're ready to go. Maybe Michael can confirm?
Comment 20 Michael Dale 2012-09-20 02:16:10 UTC
We are in sync with:
* Kaltura HTML 1.7 -- latest major release
* getid3: We are running version 1.9.3-20111213 which is the latest release: http://www.getid3.org/
Comment 21 Chris Steipp 2012-09-20 17:21:16 UTC
(In reply to comment #20)
> We are in sync with:
> * Kaltura HTML 1.7 -- latest major release
> * getid3: We are running version 1.9.3-20111213 which is the latest release:
> http://www.getid3.org/

Great, I think it's ready to deploy then
Comment 22 Michael Dale 2012-09-20 17:37:13 UTC
Its running on test2: http://test2.wikipedia.org/wiki/Special:Version

Been attempting to follow up with other folks per some minor updates, image scallers and the next wiki to deploy it on.
Comment 23 MZMcBride 2012-10-12 00:05:32 UTC
Okay, now that test2.wikipedia.org is live, can we add mediawiki.org and test.wikipedia.org? These wikis are the usual guinea pigs (cf. <https://www.mediawiki.org/wiki/MediaWiki_1.21/Roadmap#Schedule_for_the_deployments>).
Comment 24 Sage Ross 2012-10-21 03:57:09 UTC
Yes yes yes! Looks like this did get deployed to test.wikipedia.org (at least, I assume so because .webm and the Kaltura player are working).

Once 1.21wmf2 deploys on production wikis, does that mean .webm will be allowed on Commons and through the UploadWizard? Is there any sort of fanfare planned, like a blog post, or some documentation on best practices for videos now that we can do webm and (I'm assuming) closed captioning will be working again?
Comment 25 Alex Monk 2012-10-21 13:06:12 UTC
No, it's only enabled on testwiki and test2wiki currently. It's not connected to the version of MediaWiki deployed on the site. 1.21wmf2 is already deployed on all non-wikipedia sites.
Comment 26 Sage Ross 2012-10-21 13:52:28 UTC
Okay, so what's the deployment plan for this? Is there anything stopping this from moving to production sites?

@Michael Dale, I'm sure Guillaume and/or the communications team with preparing some fanfare. :)
Comment 27 Jan Gerber 2012-10-22 09:00:08 UTC
Currently one blocker is the transition of the imagescalers to precise, all required packages are in place but the update has not been done so far.

The other part, not blocking for enabling on more wikis, is transcoding, the videoscalers are in place but some changes need to be reviewed and merged before they can be used. (https://gerrit.wikimedia.org/r/#/c/28208/)
Comment 28 Sumana Harihareswara 2012-10-24 02:37:19 UTC
Gerrit change #28208 has now been merged (thanks, Faidon!), so I believe the last blocker is the upgrade on the imagescalers to Precise Pangolin.
Comment 29 Sumana Harihareswara 2012-10-24 17:42:01 UTC
The imagescaler OS upgrade is tracked in RT ticket 3210.
Comment 30 Sumana Harihareswara 2012-10-24 18:17:17 UTC
Peter's email "[Wikitech-l] All wmf imagescalers now running ubuntu 12.04 precise" clears up that blocker:  http://lists.wikimedia.org/pipermail/wikitech-l/2012-October/064019.html  We'll watch the imagescalers for issues for probably the rest of this week before declaring that we can go forward with the TMH deployment.
Comment 31 Rob Lanphier 2012-10-30 06:33:57 UTC
Adding bug 41528 as a blocker, which looks like it was introduced as part of a fix to a different thumbnailing problem.
Comment 32 billinghurst 2012-11-18 02:29:00 UTC
This seems deployed, am I missing something?
Comment 33 Andre Klapper 2012-11-20 13:48:22 UTC
Done.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links