Last modified: 2014-03-09 18:04:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26026 - Add API module for Special:FundraiserStatistics
Add API module for Special:FundraiserStatistics
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
ContributionReporting (Other open bugs)
unspecified
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://wikimediafoundation.org/w/api.php
wikimedia[unmaintained]
: fun-com, fundraising
: 32828 (view as bug list)
Depends on:
Blocks: noncoreapi
  Show dependency treegraph
 
Reported: 2010-11-20 18:49 UTC by MZMcBride
Modified: 2014-03-09 18:04 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MZMcBride 2010-11-20 18:49:55 UTC
It'd be nice if the fundraiser data (<http://wikimediafoundation.org/wiki/Special:FundraiserStatistics>) could be extracted from wikimediafoundation.org's API (<http://wikimediafoundation.org/w/api.php>).
Comment 1 Sam Reed (reedy) 2010-11-21 00:30:20 UTC
Max, isn't this a dupe of bug 25440 ?
Comment 2 Casey Brown 2010-11-21 01:14:21 UTC
(In reply to comment #1)
> isn't this a dupe of bug 25440 ?

I guess it is, because, while they're different special pages, they both deal with the ContributionReporting extension.
Comment 3 Sam Reed (reedy) 2010-11-21 01:21:55 UTC
ContributionHistory seems to redirect to FundraiserStatistics

*** This bug has been marked as a duplicate of bug 25440 ***
Comment 4 MZMcBride 2010-11-21 05:57:13 UTC
(In reply to comment #3)
> ContributionHistory seems to redirect to FundraiserStatistics

This bug (bug 26026) is about providing an API module for Special:FundraiserStatistics (<http://wikimediafoundation.org/wiki/Special:FundraiserStatistics>). Special:FundraiserStatistics has bar graphs and fundraiser statistics. An API module will allow easier export of the data for offline analysis.

Bug 25440 is about providing an API module for Special:ContributionHistory (or Special:ContributionHistory/en more specifically). Tomasz added an "emergency" redirect in r76647 from Special:ContributionHistory(/en) to Special:FundraiserStatistics. This should be reversed. Special:ContributionHistory(/en) provides a log of donor comments and amounts. Bug 25440 is about adding an API module to allow easier bot/script access to donor comments.

Re-opening (un-duping) this bug.
Comment 5 Mark A. Hershberger 2011-02-08 23:18:23 UTC
I doubt anyone will care about this until (much) later this year.
Comment 6 MZMcBride 2011-02-08 23:52:32 UTC
(In reply to comment #5)
> I doubt anyone will care about this until (much) later this year.

This should have been resolved last year (or the year before). When it gets put off like this, it gets added to the bottom of the queue. Next fundraiser, when there are a million other things to be done, nobody ever gets around to simple feature requests like this and it gets put off for another year. The "downtime" of the year is the best time to work on bugs like this.

Also, it's an API bug. Just assign it to Reedy and watch him go.

Re-opening.
Comment 7 Mark A. Hershberger 2011-02-09 00:04:57 UTC
If you think this is just a matter of assigning it to someone to get it done and you have a particular person in mind, feel free to re-assign when opening the bug.
Comment 8 Arthur Richards 2011-12-06 20:39:26 UTC
*** Bug 32828 has been marked as a duplicate of this bug. ***
Comment 9 Nemo 2013-03-29 16:20:56 UTC
I don't see any 2013 data in Special:FundraisingStatistics, is the reporting on wiki deprecated/superseded?
Comment 10 Andre Klapper 2013-04-02 08:46:41 UTC
Also wondering where the data is? Some stuff seems to be on http://samarium.wikimedia.org/ ?
Comment 11 Nemo 2013-04-02 09:00:30 UTC
(In reply to comment #10)
> Also wondering where the data is? Some stuff seems to be on
> http://samarium.wikimedia.org/ ?

Yes, looks like all the previous stats have been killed in last 2 years, but now they're working on a replacement which surfaced with that xkcd-aimed host: http://thread.gmane.org/gmane.org.wikimedia.foundation/65198
This request is apparently superseded and it got no attention in two years, so it can be considered closed I guess.
Comment 12 Matt Walker 2013-04-02 17:29:05 UTC
Yes -- we're trying very hard to move away from using Special:FundraiserStatistics and onto a limn based platform.

In the meantime; samarium provides all the data that FundraiserStatistics relied on and will continue to do so for the foreseable future.
Comment 13 MZMcBride 2013-04-03 02:26:35 UTC
(In reply to comment #12)
> Yes -- we're trying very hard to move away from using
> Special:FundraiserStatistics and onto a limn based platform.

Are there bugs filed about this? If so, can you please cross-reference those bugs on this bug? If not, can you please file those bugs and then cross-reference?

> In the meantime; samarium provides all the data that FundraiserStatistics
> relied on and will continue to do so for the foreseable future.

[[wmf:Special:FundraiserStatistics]] still exists. Can you please update its introductory text if it's no longer being updated and is now considered deprecated? I don't mind this bug being marked resolved/wontfix, but I want to see a graceful transition here.
Comment 15 MZMcBride 2013-04-03 13:17:32 UTC
I'm re-opening this for now until comment 13 (or comment 0) is addressed.
Comment 16 Matt Walker 2013-04-16 19:25:47 UTC
(In reply to comment #15)
> I'm re-opening this for now until comment 13 (or comment 0) is addressed.
I've updated per comment 13; and am pushing https://gerrit.wikimedia.org/r/#/c/59457/1 (which will get the page up to date)
Comment 17 Andre Klapper 2014-02-28 20:41:45 UTC
[[mw:Extension:ContributionReporting]] has not been maintained for a while and  has been superseded in Wikimedia Foundation by http://frdata.wikimedia.org/

It is currently unlikely that there will be any further active development of ContributionReporting.
Closing this report as WONTFIX to reflect reality.
Please feel free to reopen this report in the future if anyone takes the responsibility for active development of ContributionReporting again.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links