Last modified: 2011-07-27 18:22:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 25271 - 502 proxy error on Secure server
502 proxy error on Secure server
Product: Wikimedia
Classification: Unclassified
SSL related (Other open bugs)
All All
: Normal normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on: 19588 22982
Blocks: ssl
  Show dependency treegraph
Reported: 2010-09-23 19:01 UTC by Derk-Jan Hartman
Modified: 2011-07-27 18:22 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Derk-Jan Hartman 2010-09-23 19:01:30 UTC
I'm receiving a 502 proxy error from the secure server for a single url, namely

The description is:
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /wikipedia/en/w/index.php.

Reason: Error reading from remote server

Apache/2.2.8 (Ubuntu) mod_fastcgi/2.4.6 PHP/5.2.4-2ubuntu5.7wm1 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g Server at Port 443

I have no idea what is causing it, and have not yet tried purging, because i wanted to report the issue first.
Comment 1 Derk-Jan Hartman 2011-05-03 07:37:59 UTC
Same for

Probably related to the parser timeint out serverside. Still, the request should be available if you refresh the page, but it seems the proxy forces a purged page or something ?
Comment 2 Chris McKenna 2011-05-06 00:24:10 UTC
I'm seeing the same thing when trying to view my contributions filtered by namespace. It usually works for namespaces I have very few edits to, e.g. portal talk (5 edits) but almost never for template (103 edits) or category (71) edits.  My 8003 article space edits cause it to fail every time I've tried.
Comment 3 William Allen Simpson 2011-07-17 18:38:01 UTC
See also the reports at Bug 19588 (2009) and Bug 22982 (2010, also reported by Derk-Jan Hartman). Brion merged the former with speed and status Bug 19587, and just closed the latter as WORKSFORME. But it must not be, as the changes of March 2010 were before this report!
Comment 4 Chris Wood 2011-07-21 05:28:31 UTC
Merge with bug 19587?
Comment 5 Antoine "hashar" Musso (WMF) 2011-07-27 18:21:51 UTC
The Wikimedia Foundation operation team is rebuilding the HTTPS system from scratch that will solve this bug for good.

HTTPS has been enabled on test some days ago:

Therefore, this bug will not be fixed since the architecture is going to be replaced.

Note You need to log in before you can comment on or make changes to this bug.