Last modified: 2011-07-29 12:02:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22982 - Secure server returns proxy errors
Secure server returns proxy errors
Status: RESOLVED WORKSFORME
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Wikipedi...
:
Depends on:
Blocks: 11270 ssl 25271
  Show dependency treegraph
 
Reported: 2010-03-28 00:29 UTC by Derk-Jan Hartman
Modified: 2011-07-29 12:02 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2010-03-28 00:29:07 UTC
"secure.wikimedia.org Proxy Error 502"

"It happens when I try to get diffs, edit (it'll make the edit but not return the proper screen), and even when I'm just reading a page"

"In case it helps, here are further details of the 502 error message: Apache/2.2.8 (Ubuntu) mod_fastcgi/2.4.6 PHP/5.2.4-2ubuntu5.7wm1 with Suhosin-Patch mod_ssl/2.2.8 OpenSSL/0.9.8g Server at secure.wikimedia.org Port 443"
Comment 1 caesar_TeKfTu4q 2010-03-28 00:50:10 UTC
When editing on the secure wikimedia server, and click submit, 

https://secure.wikimedia.org/wikipedia/en/w/index.php?title=Health_care_reform_debate_in_the_United_States&action=submit

Instead of the Preview page I get

Proxy Error

The proxy server received an invalid response from an upstream server. The proxy server could not handle the request POST /wikipedia/en/w/index.php.

Reason: Error reading from remote server

Apache/2.2.8 (Ubuntu) mod_fastcgi/2
Comment 2 howard 2010-03-29 15:15:40 UTC
I see this when attempting diffs while using Firefox.
Comment 3 Roan Kattouw 2010-03-30 15:07:16 UTC
<RobH>	pls do not spend a lot of time on it
<RobH>	I am racking another server soon to be the new secure gateway.
Comment 4 Derk-Jan Hartman 2010-04-21 23:12:41 UTC
On March 31:
00:50 Tim: increased apache TimeOut setting on singer from 5 to 30 seconds, to hopefully fix multiple reports of high error rates on secure.wikimedia.org


And today:
01:11 < atglenn> yes that was fixed

I haven't seen reports on the village pumps or anything either in april.
Comment 5 Chris Wood 2011-02-03 00:58:48 UTC
Reopen, duplicate of bug 19587?
Comment 6 Brion Vibber 2011-07-15 23:18:21 UTC
Closing as a worksforme for now; if there are specific continuing issues open specific bugs for them.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links