Last modified: 2013-06-18 15:06:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24156 - Messages of log entries should support GENDER
Messages of log entries should support GENDER
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: High enhancement with 4 votes (vote)
: 1.21.0 release
Assigned To: Umherirrender
: i18n, platformeng
: 35809 (view as bug list)
Depends on: 24620
Blocks: gender
  Show dependency treegraph
 
Reported: 2010-06-28 14:00 UTC by Eugene Zelenko
Modified: 2013-06-18 15:06 UTC (History)
13 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Eugene Zelenko 2010-06-28 14:00:12 UTC
It's necessary to pass user name into this message to support GENDER.

On Slavic language there is different translation depending on gender of user who performed action.

I think other messages related to logs are possible candidate to such changes, where user name linked in software with other message and past time is used in message itself.
Comment 1 Leinad 2011-02-10 15:00:55 UTC
I've changed summary of bug - in Polish most of messages in log need GENDER support.

For example:
* [[MediaWiki:Deletedarticle]]
 - male: usunął $1
 - female: usunęła $1
* [[MediaWiki:Blocklogentry]]
 - male: zablokował $1, czas blokady: $2 $3
 - female: zablokowała $1, czas blokady: $2 $3
* [[MediaWiki:Abusefilter-log-entry-modify]]
 - male: zmodyfikował $1 ($2)
 - female: zmodyfikowała $1 ($2)
etc
Comment 2 Siebrand Mazeland 2011-02-10 16:57:03 UTC
Ties in with bug 21716 and bug 25351. Sounds like a project.
Comment 3 Purodha Blissenbach 2011-02-26 16:36:34 UTC
While you look at these, maybe having an eye on another problem at the same time may help to structurally better solutions. Details in bug 27743.
Comment 4 Amir E. Aharoni 2011-03-28 17:32:25 UTC
A question from a silly user who knows very little about the MediaWiki source code: Is there anything here to be done except passing the username as a parameter?
Comment 5 Siebrand Mazeland 2011-08-31 17:28:24 UTC
To Niklas per IRC triage.
Comment 6 Purodha Blissenbach 2011-09-03 18:21:07 UTC
See also Bug 30737
Comment 7 KPu3uC B Poccuu 2012-01-25 11:11:16 UTC
Yeah, Russian translations also need support for {{GENDER}}, some messages:
* blocklogentry.
* Prot_1movedto2.
* blocked-notice-logextract.
* ipb-disableusertalk.
* ipb-needreblock.
* Accountcreatedtext.
* Movedarticleprotection.
Incomplete list, got to go :(
Comment 8 KPu3uC B Poccuu 2012-01-25 16:31:14 UTC
Continue this list:
* All Babel related messages ("This user is able to contribut...", "user" is gender-dependent in Russian translations).
* Unblocklogentry.
* Feedback-bugornote.
* renameuserlogentry.
* Undelete-revision.
* blocked-notice-logextract.
* renameuser-renamed-notice.
* renameusersuccess.
* sp-contributions-blocked-notice.
Comment 9 KPu3uC B Poccuu 2012-01-26 06:08:41 UTC
Also message group "group-...-member".
Comment 10 Niklas Laxström 2012-01-26 07:25:20 UTC
This bug is about log entries, some of which already support gender. group-* messages already support gender.
Comment 11 Leinad 2012-02-28 11:58:10 UTC
Hi, I was going to check what new in MW 1.19 and I have just found that GENDER support for log entries has been removed :(

r1=110867&r2=110909">http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/languages/messages/MessagesPl.php?r1=110867&r2=110909

Are you going to fix this problem?
Comment 12 Leinad 2012-02-28 11:59:43 UTC
Fix link: r1=110867&r2=110909">http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/languages/messages/MessagesPl.php?r1=110867&r2=110909
Comment 13 Leinad 2012-02-28 12:01:08 UTC
Dunno what's going on... I mean r110909
Comment 14 Niklas Laxström 2012-02-28 12:02:39 UTC
I'm planning to fix the problem for 1.20.
Comment 15 Umherirrender 2012-07-08 16:02:34 UTC
(In reply to comment #14)
> I'm planning to fix the problem for 1.20.

Did you still working on this for 1.20? Thanks.
Comment 16 Niklas Laxström 2012-07-12 23:09:17 UTC
As this is only one of my pet projects, it gets pushed farther when other stuff comes up, haven't had that much time for other stuff lately, so help would be appreciated.
Comment 17 Umherirrender 2012-07-13 14:06:11 UTC
(In reply to comment #16)
> As this is only one of my pet projects, it gets pushed farther when other stuff
> comes up, haven't had that much time for other stuff lately, so help would be
> appreciated.

With Gerrit change #4506 one part was already done, because with that change the GENDER parser function is using the GenderCache and that Cache is filled by the LinkBatch which is already there. In the most case the gender state will be already populated for the log and not generating one query per parser function call.
Comment 18 Siebrand Mazeland 2012-08-22 10:36:08 UTC
*** Bug 35809 has been marked as a duplicate of this bug. ***
Comment 19 Umherirrender 2012-08-27 19:16:38 UTC
Tim, can you have a look at this?

You have removed the GENDER from all log message with r110909, due to performance reason.
In the meantime things changed, see comment 17, maybe it is possible to put the GENDER back?

Thanks.
Comment 20 Nemo 2012-11-20 18:26:42 UTC
Adjusting priority field according to real needs.
This is a hard fix, apparently, bug this doesn't make it less needed; it's one of the most needed ones.
Also setting 1.21 as milestone (it would probably be one of main achievements for the release).

(In reply to comment #19)
> Tim, can you have a look at this?
> 
> You have removed the GENDER from all log message with r110909, due to
> performance reason.
> In the meantime things changed, see comment 17, maybe it is possible to put the
> GENDER back?
Comment 21 Pavel Selitskas [wizardist] 2013-02-24 01:31:26 UTC
Is it safe to bring GENDER to the messages back? Does the GenderCache work properly so there is no unreasonable overhead? If so, I can do it, just give me an update.
Comment 22 Andre Klapper 2013-03-01 19:23:39 UTC
(In reply to comment #20)
> Adjusting priority field according to real needs.
> it's one of the most needed ones.

I understand this is very annoying for specific languages, but I'd love to see arguments listed in this bug report when enhancement requests get bumped to high priority and nobody is assigned to them yet. Comment 10 and comment 17 imply that support is in places for some cases (if I don't get it wrong).
Comment 23 Nemo 2013-03-01 19:33:46 UTC
(In reply to comment #22)
> (In reply to comment #20)
> > Adjusting priority field according to real needs.
> > it's one of the most needed ones.
> 
> I understand this is very annoying for specific languages, but I'd love to
> see
> arguments listed in this bug report 

Arguments: general guideline/policy https://www.mediawiki.org/wiki/Localisation#Users_have_grammatical_genders

> when enhancement requests get bumped to
> high priority and nobody is assigned to them yet. 

"High priority" now means "within six months if possible", so it's surely not excessive.

> Comment 10 and comment 17
> imply that support is in places for some cases (if I don't get it wrong).

Comment 10 is before everything was reverted, and comment 17 only mentions a change that should help reverting the revert. Nothing was done yet.
Comment 24 Umherirrender 2013-03-01 20:24:40 UTC
Nobody reverts Tim Starling reverts ;-), so we need him, that he can say, if the revert of the revert would be safe and not bring to many load at wmf servers, when genders allows on log messages.
Comment 25 Umherirrender 2013-03-16 20:18:38 UTC
I have readd the gender to english logentry messages with Gerrit change #54143

Some languages are already using gender, so why not all?
Comment 26 Umherirrender 2013-03-17 08:55:24 UTC
(In reply to comment #25)
> I have readd the gender to english logentry messages with Gerrit change
> #54143

successfully merged

All log types rewritten with the LogFormatter can now use GENDER in the translation.
Comment 27 Andre Klapper 2013-03-20 15:38:53 UTC
(In reply to comment #26)
> successfully merged
> 
> All log types rewritten with the LogFormatter can now use GENDER in the
> translation.

So can this report be closed as FIXED, or which steps are missing?
Comment 28 Pavel Selitskas [wizardist] 2013-03-21 14:07:32 UTC
(In reply to comment #27)
> (In reply to comment #26)
> > successfully merged
> > 
> > All log types rewritten with the LogFormatter can now use GENDER in the
> > translation.
> 
> So can this report be closed as FIXED, or which steps are missing?

GENDER seems working in log entries, although I cannot say anything about perfomance.
Comment 29 Umherirrender 2013-03-21 17:21:54 UTC
Not all log types are rewritten with the LogFormatter, so not all log types supports gender. It looks easier to close this and use other bugs (some exists!?) for the log rewrite of other log types.
Comment 30 Nemo 2013-03-21 17:26:32 UTC
(In reply to comment #29)
> Not all log types are rewritten with the LogFormatter, so not all log types
> supports gender. It looks easier to close this and use other bugs (some
> exists!?) for the log rewrite of other log types.

Bug 24620 exists. :) It's currently marked as blocker of this bug (technically wrong if that's open and this is closed).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links