Last modified: 2011-09-09 08:42:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 30737 - User names should be moved into log messages.
User names should be moved into log messages.
Status: RESOLVED DUPLICATE of bug 21716
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.20.x
All All
: Unprioritized enhancement with 1 vote (vote)
: ---
Assigned To: Niklas Laxström
: i18n
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-03 18:20 UTC by Purodha Blissenbach
Modified: 2011-09-09 08:42 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Purodha Blissenbach 2011-09-03 18:20:35 UTC
This is closely related to bug 24156 but is an independant issue.

Currently, log messages referring to a user name - usually the
user who caused the log entry to be created by doing something - 
list the user name in a quasi tabular format in front of the
message telling what exactly happened.

In English, this can be read as "user-name caused this and that."
giving a nice sentence. Messages are worded accordingly. This
does not translate to languages, where "user-name" cannot be
the first word in a sentence. (Grammar, syntax, word order,
good taste or style, and politeness rules may be prohibiting)

It might thus be advisable, to tie the user name into the
message text so as to allow it to appear at any place in a
sentence.

This gives up, however, some of the ease of machine processing
coming with its current fixed position. My current opinion is
that machine readable logs should be availabe much better via
the API, and fixed positioning should be given up in favour of
better i18n and language support.

The possible half-way solution, keeping the tabular user name
and passing the user name to the message handling of the textual
part, would allow genderized messsages, and the message could
even repeat the user name instead of using "this user" etc.,
but I think that makes log entries less readable.

We could of course include the user names in the message texts
andkeep the tabular user name field, assigning it to a
display:none CSS class. This increases log page size.
Yet this dupliction, without display:none, may be a good interim
solution while messages are beeing adopted to the new style.
Another way to make a transit could be to identify all
messages being used for logging, insert "[[user:$1|$1 "
at their beginning in all message source files, and alter
message handling function calls accordingly. Thus, translators
had unlimited time to fix them.
Comment 1 Niklas Laxström 2011-09-03 18:26:20 UTC
(In reply to comment #0)
> This gives up, however, some of the ease of machine processing
> coming with its current fixed position.

We have API for machines. The log pages are for humans.
Comment 2 Siebrand Mazeland 2011-09-03 18:42:16 UTC
I think this issue should be closed as a duplicate of bug 24156, as I think the solution for bug 24156 will involve adding the user name and no longer requiring it to be "first in sentence". If this is correct, please close this as a dupe, Niklas.
Comment 3 Niklas Laxström 2011-09-09 08:42:47 UTC

*** This bug has been marked as a duplicate of bug 21716 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links