Last modified: 2012-08-22 10:36:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 35809 - GENDER magic word doesn't work in Serbian
GENDER magic word doesn't work in Serbian
Status: RESOLVED DUPLICATE of bug 24156
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: gender
  Show dependency treegraph
 
Reported: 2012-04-08 03:01 UTC by Rancher
Modified: 2012-08-22 10:36 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rancher 2012-04-08 03:01:36 UTC
I won't go in details since I already discussed about this on MediaWiki's IRC room. I'll just say this: My gender on Wikipedia is set to male. I checked all types of logs and every single user is displayed in male form (regardless of the gender). When I change my gender to female, it's a different story. Then it depends on type of the action. All the messages in block, protection and upload logs are displayed in female forms, and all the other log messages are in male forms.

Epiphany: I just logged in some pastebin site after a while and found a list of log messages I uploaded before, without username variables. And those messages are displayed wrongly on Serbian Wikipedia! I finally realized what was this fuzz all about. You need to include username variables to these messages in order for them to work: http://tinypaste.com/8660f. I remember this was reported a couple of times before, but no progress was made since.
Comment 1 Niklas Laxström 2012-04-08 09:32:23 UTC
I did major log system refactoring less than year ago. To take advantage of new features like gender support, each log type must be converted separately. Only few log types are currently converted and support gender.
Comment 2 Siebrand Mazeland 2012-08-22 10:36:08 UTC

*** This bug has been marked as a duplicate of bug 24156 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links