Last modified: 2014-07-21 15:43:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21798 - No error message for omitted </ref> tag
No error message for omitted </ref> tag
Status: RESOLVED DUPLICATE of bug 15712
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 27075 67845 (view as bug list)
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2009-12-08 18:22 UTC by FT2
Modified: 2014-07-21 15:43 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description FT2 2009-12-08 18:22:03 UTC
A cite missing a </ref> tag will be reported as missing a <references /> tag instead. Example:

   Fact fact fact.<ref>source.com

   More fact fact fact...

   ==References==
   <References />

renders with the error "There are <ref> tags on this page, but the references will not show without a <references/> tag", not "there is a missing </ref> tag".
Comment 1 Bryan Baron 2009-12-09 02:19:41 UTC
Suggest WONTFIX. A <references /> tag after a </ref> won't be detected because everything after the unclosed <ref> will be parsed as a reference (so the nested <references /> won't work). So, while the current message is a bit misleading, in a certain way it's correct.
Comment 2 FT2 2009-12-09 02:34:08 UTC
Surely it's easy to check every <ref> is followed by a </ref>. REF tags can't presently be nested, so this is trivial to check. If an unclosed <ref> is detected, indicate this in the error message. 

When there are no missing </ref>'s then show the current message instead.
Comment 3 John Mark Vandenberg 2011-05-06 11:37:25 UTC
*** Bug 27075 has been marked as a duplicate of this bug. ***
Comment 4 Nemo 2013-11-19 12:36:14 UTC
Adding many blockers of bug 38638 to the list of "easy" bugs, to mark them as candidates for [[mw:Google Code-in]] tasks (gci2013). If you think this bug is not suitable, remove the keyword.
Comment 5 Gerrit Notification Bot 2014-03-20 14:13:36 UTC
Change 119743 had a related patch set uploaded by AalekhN:
Adds proper error message

https://gerrit.wikimedia.org/r/119743
Comment 6 Gadget850 2014-07-11 13:39:33 UTC
With the resolution of Bug 66860, there is no longer any error generated for this issue, it just renders the rest of the page oddly. See bug 67845.
Comment 7 Alex Monk 2014-07-17 23:06:07 UTC
*** Bug 67845 has been marked as a duplicate of this bug. ***
Comment 8 Alex Monk 2014-07-17 23:08:55 UTC
Patch doesn't do what we want and clearly isn't going to be fixed - setting NEW status. Are we sure this is an easy bug? Sounds like it would require a good knowledge of the parser to do...
Comment 9 Gerrit Notification Bot 2014-07-17 23:09:49 UTC
Change 119743 abandoned by Alex Monk:
Adding proper error message

Reason:
Seems abandoned to me at this point. Feel free to restore if you're going to address the issues though.

https://gerrit.wikimedia.org/r/119743
Comment 10 James Forrester 2014-07-17 23:20:55 UTC
AFAICS there's no special i18n issue here. Removing tag.
Comment 11 Gadget850 2014-07-21 14:53:18 UTC
With the resolution of Bug 66860, a missing reference list is now automatically added. Before this was deployed, a page with a missing </ref> tag near the end of a page would eat the <references /> tag; this would trigger the error for a missing <references /> tag and editors were alerted that there was a problem. Now, there is no error and the following markup is rendered oddly.

Simple example:

<ref>1

<references />

Since there is no error detection, this is going to be a persistent issue and will be very difficult for novice editors to sort out. On enwiki, we had customized the error message so it linked to a help page that noted that the issue could be due to a missing </ref>.
Comment 12 Gadget850 2014-07-21 14:58:10 UTC
Duplicate of Bug 15712
Comment 13 James Forrester 2014-07-21 15:43:19 UTC
(In reply to Gadget850 from comment #12)
> Duplicate of Bug 15712

Agreed.

*** This bug has been marked as a duplicate of bug 15712 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links