Last modified: 2013-11-23 19:09:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21117 - Raise the default thumbnail image size from 180px to 220px on remaining Wikimedia wikis
Raise the default thumbnail image size from 180px to 220px on remaining Wikim...
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Normal normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org
: shell
: 11393 23587 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 16:32 UTC by Tony Souter
Modified: 2013-11-23 19:09 UTC (History)
17 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Tony Souter 2009-10-12 16:32:57 UTC
A two-week RfC here:

http://en.wikipedia.org/wiki/Wikipedia_talk:Image_use_policy#Further_discussion

has produced decisive consensus for raising the default thumbnail size on en.WP from 180 to 220px. The RfC was widely advertised and there was little change in overall preferences as the RfC progressed. Many editors would like the increase to be more (including me), say 230px, but in terms of safe, practical decision-making, nothing beats the 80% of participants who found 220px acceptable. This would be a non-controversial and popular action. The yellow-blue graphs half-way down that section show the profile of community opinion from this sample.

Is it possible for a developer to put this into effect?

Thanks in advance.
Comment 1 Roan Kattouw 2009-10-12 19:12:13 UTC
For Rob's convenience, the required LocalSettings statements are:

$wgThumbLimits = array(
	120,
	150,
	180,
	200,
	220,
	250,
	300
);
$wgDefaultUserOptions['thumbsize'] = 4;

This would add 220px as a thumb size option and automatically set it for anonymous users and all registered users currently having it set to 180 (AFAIK).
Comment 2 Jarry1250 2009-10-13 16:06:40 UTC
(In reply to comment #1)
> 
> This would add 220px as a thumb size option and automatically set it for
> anonymous users and all registered users currently having it set to 180
> (AFAIK).
> 

I was under the impression that this was not the case, since the default was just copied in when they registered - thus no way of knowing whether or not the user had changed it in the future.

OTOH, presumably if numbers are stored in the user table, they are the index numbers of their choice in the array, and if we change the array... everything goes out of sync? Hence, you may well be correct. I don't know enough to say.
Comment 3 Brion Vibber 2009-10-14 17:48:56 UTC
Jarry, with our current prefs infrastructure folks using the defaults will be automatically updated to the new default, at least in theory. :)

Rob, I think I'd be fine with sticking 220 in as the sitewide default. 180 does indeed feel a bit small these days.
Comment 4 Tony Souter 2009-11-01 13:40:43 UTC
Rob, any idea when this will be looked at?
Comment 5 Tony Souter 2009-11-04 12:15:24 UTC
Could someone let us know whether action will be taken, please? It's now three weeks since Brion said "I think I'd be fine with sticking 220 in as the sitewide default. 180 does
indeed feel a bit small these days."

It's just that, also by three weeks ago, the en.WP community decided by a large margin at the RfC that 220px would be better than 180px. Sorry to pester, but I need to report back at that page.
Comment 6 Roan Kattouw 2009-11-04 12:24:39 UTC
(In reply to comment #5)
> Could someone let us know whether action will be taken, please? It's now three
> weeks since Brion said "I think I'd be fine with sticking 220 in as the
> sitewide default. 180 does
> indeed feel a bit small these days."
> 
> It's just that, also by three weeks ago, the en.WP community decided by a large
> margin at the RfC that 220px would be better than 180px. Sorry to pester, but I
> need to report back at that page.
> 

As it seems Rob doesn't have time for it (I've noticed he's busy with other things), I'll roll out this config change around 19:00 UTC (11am PST, 8pm CET) after consulting the ops folks about the spike in thumbnail regeneration this could cause.
Comment 7 Tony Souter 2009-11-04 12:27:42 UTC
Ah, thank you very much, Roan. I won't post anything at en.WP until I know the ops people are OK about it.
Comment 8 Roan Kattouw 2009-11-04 19:07:22 UTC
(In reply to comment #6)
> As it seems Rob doesn't have time for it (I've noticed he's busy with other
> things), I'll roll out this config change around 19:00 UTC (11am PST, 8pm CET)
> after consulting the ops folks about the spike in thumbnail regeneration this
> could cause.
> 
Change of plans: since the guy who knows most about the uploading and thumbnailing infrastructure isn't around right now, I'm gonna wait till I get hold of him.
Comment 9 Roan Kattouw 2009-11-05 11:13:52 UTC
(In reply to comment #8)
> Change of plans: since the guy who knows most about the uploading and
> thumbnailing infrastructure isn't around right now, I'm gonna wait till I get
> hold of him.
> 
I talked to Ariel, and he's not convinced that the scalers can handle it: all images used on enwiki would have to be rethumbnailed within a relatively short time. Before we do this, Ariel wants to have a few spare machines that can be thrown into the scaler pool at short notice, and wants to be around to do that. Currently, neither is the case.

Summary: not happening right now, we need more servers first.
Comment 10 Platonides 2009-11-07 22:30:00 UTC
They could be pre-thumbnailed offline before flipping the switch.
Comment 11 Tony Souter 2009-12-11 13:10:10 UTC
Dear friends,

I've sent the following message to Ariel, asking for advice about when the spare capacity might be available to achieve the increase from 180 to 220 px:


"Ariel, after extensive discussion and an RfC, en.WP decided with overwhelming consensus that it wants to move the default width of thumbnail images from 180 to 200 pixels.

The request to do this technically was filed at Bugzilla on 10 October [link provided] and allocated to Rob Halsell. I refer to Roan Kattouw's 5 November comment, that:

<blockquote>I talked to Ariel, and he's not convinced that the scalers can handle it: all
images used on enwiki would have to be rethumbnailed within a relatively short
time. Before we do this, Ariel wants to have a few spare machines that can be
thrown into the scaler pool at short notice, and wants to be around to do that.
Currently, neither is the case.

Summary: not happening right now, we need more servers first.</blockquote>

The number of queries as to when the change will be made is increasing. I wonder whether you can advise us when the spare capacity might be available to achieve this important upgrade.

I've emailed this message to you at ariel@wikimedia.org and have copied it to the Bugzilla page and [http://en.wikipedia.org/wiki/Wikipedia_talk:Image_use_policy#I.27ve_contacted_WMF.27s_Ariel_Glenn_about_the_thumbnail_increase en.WP's Image Use Policy talk page].

Thanks for your time, [http://en.wikipedia.org/wiki/User_talk:Tony1 Tony1 at en.WP]"
Comment 12 Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-12-11 15:01:54 UTC
In discussion in #wikimedia-tech, it was also pointed out that having different thumb sizes for different projects would double the Squid cache usage for Commons images used in multiple projects.  If this is an issue, it might make more sense to increase the default globally or not at all.  A larger default thumb size probably makes sense on all projects given the increasing resolution of typical monitors.
Comment 13 Tony Souter 2009-12-11 15:07:22 UTC
Aryeh, I was told the Swedish WP, among the largest WPs, is already on a default size of 250px. Looking now, they seem to be generously sized. Is there some way of telling what the defaults are for each WP? 
Comment 14 Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-12-11 15:11:58 UTC
Configuration should be here:

http://noc.wikimedia.org/conf/

I don't see $wgThumbLimits changed for any wiki, but I might just be missing it.
Comment 15 Tony Souter 2009-12-11 15:16:29 UTC
I just tried the map of the US and the "Teton Range" pics here in preview mode:

http://sv.wikipedia.org/wiki/USA#Geografi_och_milj.C3.B6

They look exactly the same size when "250px|" is added to the syntax.
Comment 16 Platonides 2009-12-11 19:18:05 UTC
The default thumb size is 180 for all wikis but sv wikipedia (250px) and it wikiquote (200px).

InitialiseSettings.php:

'wgThumbLimits' => array(
   'default' => array( 120, 150, 180, 200, 250, 300 ),
   'itwikiquote' => array( 120, 150, 200, 250, 300, 360 ),
   'svwiki' => array( 120, 200, 250, 300, 360 ),
),
Comment 17 Bryan Baron 2009-12-18 16:41:42 UTC
To save SquidCache I think that all WMF projects should have the same default thumb size. Something around the named 220px.
Comment 18 Guillaume Paumier 2009-12-31 00:13:47 UTC
If the technical infrastructure allows it, I would lean in support of raising the default thumb size globally; 220 or 250 seem to be good choices.

If we turn this request into a global one, we should mark bug 11393 as duplicate of this one.
Comment 19 Tony Souter 2009-12-31 00:36:30 UTC
But WHEN is it going to happen? The Japanese WP has put in a request, too.

https://bugzilla.wikimedia.org/show_bug.cgi?id=11393

Can the issues raised here – specifically, (1) when there will be enough spare capacity to do the rescaling, and (2) whether it should be done for all WPs, but given priority at the next technical meeting, please?

Comment 20 Guillaume Paumier 2009-12-31 00:41:36 UTC
(In reply to comment #19)
> But WHEN is it going to happen?

When it can happen.
Comment 21 Mark Bergsma 2010-02-15 22:33:01 UTC
I just upped the default size on enwiki to 220px, but this is a load test and is likely to get reverted soon.

We'll want to try and get all wikis to the same setting for the final setting indeed.
Comment 22 Tony Souter 2010-02-16 01:50:33 UTC
This is very welcome, Mark, even if only temporary. Our fingers are crossed for permanence.
Comment 23 Nemo 2010-02-17 00:23:20 UTC
(In reply to comment #21)
> We'll want to try and get all wikis to the same setting for the final setting
> indeed.

I think that we at it.wikiquote would be ok with a 220px default size, so when and if you want to globally change it no problem for us.
Comment 24 Derk-Jan Hartman 2010-04-06 11:28:14 UTC
Done for Commons on April 6:


10:16 <+logmsgbot> !log mark synchronized php-1.5/wmf-config/InitialiseSettings.php  'Add 220px thumbnail size option for Commons'

10:17 <+logmsgbot> !log mark synchronized php-1.5/wmf-config/CommonSettings.php  'Set 220px as default thumbnail size on Commons'
Comment 25 Derk-Jan Hartman 2010-05-17 19:08:14 UTC
Done for commons and en.wp so far.
Comment 26 JeLuF 2010-05-19 04:54:13 UTC
*** Bug 23587 has been marked as a duplicate of this bug. ***
Comment 27 Nemo 2010-06-10 07:52:43 UTC
Done by Roan for top-10 wikis: https://wikitech.wikimedia.org?diff=26926
Comment 28 Roan Kattouw 2010-06-10 09:44:54 UTC
*** Bug 11393 has been marked as a duplicate of this bug. ***
Comment 29 Roan Kattouw 2010-11-07 11:07:12 UTC
Done for all wikis quite a while ago.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links