Last modified: 2009-04-18 13:45:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18263 - Single quote in file name confuses reupload form
Single quote in file name confuses reupload form
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Uploading (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://commons.wikimedia.org/w/index....
:
: 18500 18503 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 21:24 UTC by Lupo
Modified: 2009-04-18 13:45 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Lupo 2009-03-30 21:24:09 UTC
Go to the re-upload form for file [[File:Insigne de l'ETAP.jpg]] on the Commons:

http://commons.wikimedia.org/w/index.php?title=Special:Upload&wpDestFile=Insigne_de_l%27ETAP.jpg&wpForReUpload=1

The XHTML is invalid, it contains

<input tabindex='2' type='hidden' name='wpDestFile' id='wpDestFile' 
value='Insigne_de_l'ETAP.jpg' /><tt>Insigne_de_l'ETAP.jpg</tt>

'Insigne_de_l'ETAP.jpg' is not a valid string.

As a result, you cannot upload a file, the server will always respond
"The file has no extension (like ".jpg")." (At least in Firefox, because
FF passes "Insigne_de_l" as the value and ignores the rest.)

Somehow, the single quote in the file name does not get escaped.

See also http://commons.wikimedia.org/wiki/Commons:Bistro#Pb_de_t.C3.A9l.C3.A9chargement_d.27une_nouvelle_version
Comment 1 Aaron Schulz 2009-03-30 23:32:05 UTC
Fixed in r49051
Comment 2 Splarka 2009-04-18 11:27:48 UTC
*** Bug 18500 has been marked as a duplicate of this bug. ***
Comment 3 Gregor Hagedorn 2009-04-18 12:15:39 UTC
As of today, commons is working with r48811. Can commons be updated to r49051? In practice, the bug is NOT resolved, because the resolution is not available.
Comment 4 Niklas Laxström 2009-04-18 12:28:44 UTC
The common practise is to mark bugs as resolved when the fix is applied. This does not mean that Wikimedia Foundation has or has not updated their code. Those updates usually take weeks, except for some things which are updated out-of-cycle.
Comment 5 Splarka 2009-04-18 13:45:51 UTC
*** Bug 18503 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links