Last modified: 2011-03-15 11:10:16 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17160 - Gender specific display text for User namespace
Gender specific display text for User namespace
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.17.x
All All
: Normal enhancement with 3 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
: 26927 (view as bug list)
Depends on:
Blocks: 27681 28052
  Show dependency treegraph
 
Reported: 2009-01-26 17:30 UTC by Leinad
Modified: 2011-03-15 11:10 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Leinad 2009-01-26 17:30:14 UTC
When you update MW code with gender switch in user preferences (bug 13040), please namespace aliases "Wikipedystka" and "Dyskusja_wikipedystki" (bug 10064) relate to female option.
Comment 1 Leinad 2010-10-16 12:36:10 UTC
Hello!

Is there any progress with this issue? It's very sad that women are discriminated against and do not have a namespace corresponding to the set of gender in Special:Preferences.

The problem concerns not only the Polish language, but also other Slavic languages.
Comment 2 Roan Kattouw 2010-10-16 12:50:27 UTC
(In reply to comment #0)
> When you update MW code with gender switch in user preferences (bug 13040),
> please namespace aliases "Wikipedystka" and "Dyskusja_wikipedystki" (bug 10064)
> relate to female option.

I don't understand this request. Could you be more clear about what you want? The aliases you mention already exist.
Comment 3 Leinad 2010-10-16 13:10:46 UTC
> I don't understand this request. Could you be more clear about what you want?
> The aliases you mention already exist.

Yes, aliases exist, but are not visible as regular namespace.

When woman set in [[Special:Preferences]] gender "female", the name of namespace should have feminine form.

For example in Polish Wikipedia:
- Male/Unspecified is [[Wikipedysta:]] ([[User:]]) and [[Dyskusja wikipedysty:]] ([[User_talk:]])
- and Female should be [[Wikipedystka:]] and [[Dyskusja wikipedystki:]]
Comment 4 Leinad 2010-10-16 14:29:33 UTC
Ok, maybe I'll try to clarify...

The proper gender form of namespace should be visible on pages [[User:]] and [[User_talk:]] (in URL, tab and <h1> header).

But both gender forms should be treated by software as the same namespace (for example on [[Special:AllPages]] - http://pl.wikipedia.org/w/index.php?title=Specjalna:Wszystkie+strony&from=&to=&namespace=2).
Comment 5 Roan Kattouw 2010-10-16 16:24:54 UTC
The MediaWiki software currently does not support this. A namespace can only have one primary name (Wikipedysta in this case), one canonical name (always the English name, so User in this case) and any number of aliases (in this case, only Wikipedystka).

Having the feminine variant of "User" show up on female users' user pages is not just a configuration switch that can be flipped, it needs to be coded into MediaWiki first. Repurposing this bug for that.
Comment 6 Guillaume Paumier 2011-01-25 11:12:34 UTC
*** Bug 26927 has been marked as a duplicate of this bug. ***
Comment 7 Siebrand Mazeland 2011-02-10 16:55:18 UTC
IIRC Niklas has in the past made a hack for this at twn or might have even committed it.
Comment 8 Liangent 2011-02-10 17:02:41 UTC
1) Solution used in the Language Converter to convert namespace names to different variants may be useful. (Make the primary one English, Wikipedysta and Wikipedystka aliases, and change it on display)

2) I guess Wikipedysta or Wikipedystka means Wikipedian. Should a word with a meaning of "User" be used?
Comment 9 Mark A. Hershberger 2011-02-10 17:08:52 UTC
Is there a gender-neutral word for "User"?

But yes, a word meaning "User" would be better, I think.  You can work towards that change on TranslateWiki.
Comment 10 Leinad 2011-02-10 17:14:21 UTC
(In reply to comment #8)
> 2) I guess Wikipedysta or Wikipedystka means Wikipedian. Should a word with a
> meaning of "User" be used?

Yes, "Wikipedysta" and "Wikipedystka" are a names for users of Wikipedia.

Default names for MediaWiki installation should be "Użytkownik" (male) and "Użytkowniczka" (female).
Comment 11 Leinad 2011-02-10 17:53:23 UTC
(In reply to comment #9)
> Is there a gender-neutral word for "User"?

In Polish - no (and probably the same sitution in other Slavic languages).

We use the masculine form as a gender-neutral, *only* if we do not have in mind a specific person. But if I know that I speak with a woman, then I use the feminine form - if someone uses the masculine form it is very rude.
Comment 12 Helder 2011-02-10 18:13:28 UTC
(In reply to comment #11)
> (In reply to comment #9)
> > Is there a gender-neutral word for "User"?
> 
> In Polish - no (and probably the same sitution in other Slavic languages).
> 
> We use the masculine form as a gender-neutral, *only* if we do not have in mind
> a specific person. But if I know that I speak with a woman, then I use the
> feminine form - if someone uses the masculine form it is very rude.

The same applies for Portuguese. See for example this discussion: 
http://pt.wikipedia.org/wiki/Wikip%C3%A9dia:Esplanada/propostas/Altera%C3%A7%C3%A3o_nos_nomes_dos_dom%C3%ADnios_de_discuss%C3%A3o_(10dez2010)

Not only there are different words used for masculine/feminine, but also, for different variants of Portuguese, e.g. pt-PT and pt-BR.

Currently, the pt-BR/masculine word "Usuário" is used, but this situation is far from ideal, since it is not adequate for pt-PT, pt-AO, pt-... users and for female users neither.
Comment 13 Niklas Laxström 2011-02-11 15:23:20 UTC
I've been working a new patch on my free time. The remaining issues are mostly about efficiency.
Comment 14 Niklas Laxström 2011-02-11 21:07:53 UTC
Somewhat tested patch is at http://translatewiki.net/sandwiki/gender.txt . It works fine for me, but I would like to have it tested in a language that really uses those.
Comment 15 Ilmari Karonen 2011-02-12 17:13:54 UTC
(In reply to comment #14)
> Somewhat tested patch is at http://translatewiki.net/sandwiki/gender.txt .

Minor suggestion: the structure you suggest for the $namespaceGenderAliases array looks kind of ugly to me.  Something like

 $namespaceGenderAliases = array(
         NS_USER => array( 'male' => 'Male_user', 'female' => 'Female_user' ),
 );

would make more sense to me.

Also, you might want to skip the GenderCache::needed() "shortcut" and just call $wgContLang->needsGenderDistinction() from LinkBatch directly.  That way you should be able to avoid loading GenderCache.php at all for wikis that don't need it.

The rest of it looks pretty good to me, though.
Comment 16 Niklas Laxström 2011-02-12 20:49:20 UTC
See r82029
Comment 17 Leinad 2011-02-13 19:19:14 UTC
(In reply to comment #16)
> See r82029

Yay! This is wonderful suprise :))

I have some observations/questions:
* I tried add $namespaceGenderAliases via LocalSettings.php, but it is not work - only works via MessagesPl.php. 
* Are you planning to allow add default names in $namespaceGenderAliases via platform translatewiki or I should request in new bug?
* Gender form is visible only in <h1> and URL, but not in tab. In my opinion if $namespaceGenderAliases is enabled, there should exist MediaWiki messages for tab with proper gender form.
Comment 18 Niklas Laxström 2011-02-13 20:47:48 UTC
(In reply to comment #17)
> I have some observations/questions:
> * I tried add $namespaceGenderAliases via LocalSettings.php, but it is not work
> - only works via MessagesPl.php. 

Yes, it is like any other variable in MessagesXx.php

> * Are you planning to allow add default names in $namespaceGenderAliases via
> platform translatewiki or I should request in new bug?

Currently there is no way to add them directly in twn. Should be done either in bugzilla or through Support on twn. Sorry I didn't actually read the first comment in this bug.

> * Gender form is visible only in <h1> and URL, but not in tab. In my opinion if
> $namespaceGenderAliases is enabled, there should exist MediaWiki messages for
> tab with proper gender form.

Was it you or someone else which suggested the workaround {{GENDER:{{BASEPAGENAME}}|...}}. Anyway, could you open a separate bug for it so that I don't forget it.
Comment 19 Leinad 2011-02-13 21:46:09 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > I have some observations/questions:
> > * I tried add $namespaceGenderAliases via LocalSettings.php, but it is not work
> > - only works via MessagesPl.php. 
> 
> Yes, it is like any other variable in MessagesXx.php

Sorry, but I'm not sure... $namespaceGenderAliases will be not possible to set in LocalSettings.php? I thought will be the same as $wgExtraNamespaces. For example:

In default MediaWiki instalaltion there is (http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/languages/messages/MessagesPl.php?view=markup):
$namespaceNames = array(
       NS_USER             => 'Użytkownik',
);

but in own installation is possible to set own name (http://noc.wikimedia.org/conf/highlight.php?file=InitialiseSettings.php):
'wgExtraNamespaces' => array(
    'plwiki' => array( 
        NS_USER => 'Wikipedysta',
    ),
),


> > * Gender form is visible only in <h1> and URL, but not in tab. In my opinion if
> > $namespaceGenderAliases is enabled, there should exist MediaWiki messages for
> > tab with proper gender form.
> 
> Was it you or someone else which suggested the workaround
> {{GENDER:{{BASEPAGENAME}}|...}}. Anyway, could you open a separate bug for it
> so that I don't forget it.

Ok, done bug27387.
Comment 20 Niklas Laxström 2011-02-14 07:36:41 UTC
For WMF it can be specified in WikimediaMessages extension, for other installs another extension is needed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links