Last modified: 2014-08-06 22:59:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 67023 - AJAX review errors show HTML markup in notification
AJAX review errors show HTML markup in notification
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
FlaggedRevs (Other open bugs)
master
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Fomafix
:
: 67484 (view as bug list)
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2014-06-24 09:02 UTC by Derk-Jan Hartman
Modified: 2014-08-06 22:59 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screenshot of the problem (42.00 KB, image/jpeg)
2014-06-24 09:02 UTC, Derk-Jan Hartman
Details

Description Derk-Jan Hartman 2014-06-24 09:02:55 UTC
Created attachment 15707 [details]
screenshot of the problem

The AJAX implementation of flagged revs, returns html fragments in case of errors: <p><b>Unable to review this revision</b></p><p>Permission denied</p>.

This textual html fragment is passed straight to mw.notify, but mw.notify can only handle: HTML dom, jQueryElements, a message key or plain text.
Comment 1 Michael M. 2014-07-05 07:48:39 UTC
*** Bug 67484 has been marked as a duplicate of this bug. ***
Comment 2 Umherirrender 2014-07-05 08:20:55 UTC
Affected message key for better search result: 'revreview-failed'
Comment 3 Gerrit Notification Bot 2014-08-06 22:34:51 UTC
Change 152186 had a related patch set uploaded by Bartosz Dziewoński:
Parse HTML in JavaScript failure notices

https://gerrit.wikimedia.org/r/152186
Comment 4 Gerrit Notification Bot 2014-08-06 22:50:38 UTC
Change 152186 abandoned by Bartosz Dziewoński:
Parse HTML in JavaScript failure notices

Reason:
Bah…

https://gerrit.wikimedia.org/r/152186
Comment 5 Gerrit Notification Bot 2014-08-06 22:51:07 UTC
Change 147320 had a related patch set uploaded by Bartosz Dziewoński:
Do not show raw HTML code in notification

https://gerrit.wikimedia.org/r/147320
Comment 6 Gerrit Notification Bot 2014-08-06 22:58:04 UTC
Change 147320 merged by jenkins-bot:
Do not show raw HTML code in notification

https://gerrit.wikimedia.org/r/147320
Comment 7 Bartosz Dziewoński 2014-08-06 22:59:04 UTC
Turns out this had a patch by Fomafix pending for almost three weeks.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links