Last modified: 2014-06-10 20:13:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 66348 - Some of the hebrew characters are not in proper order
Some of the hebrew characters are not in proper order
Status: RESOLVED INVALID
Product: MediaWiki extensions
Classification: Unclassified
CharInsert (Other open bugs)
REL1_23-branch
All All
: High normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: code-update-regression, i18n
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2014-06-08 19:25 UTC by ineuw
Modified: 2014-06-10 20:13 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
displays correct & incorrect character order (7.52 KB, image/jpeg)
2014-06-08 19:25 UTC, ineuw
Details
Showing the incorrect order of hebrew characters feom Charinsert (3.84 KB, image/jpeg)
2014-06-09 17:17 UTC, ineuw
Details

Description ineuw 2014-06-08 19:25:23 UTC
Created attachment 15595 [details]
displays correct & incorrect character order

Noticed in Wikisource version 1.24wmf7 (b8870ae) that the Hebrew character order was literally reversed from its old left to right order which placed some of the Hebrew "end" characters before the normal character. This is also true in the Wikipedia Charinsert, so I assume that it's a universal issue.

Attached please find a combined screenshot of the Charinsert with the incorrect order, and from the en.Wikipedia page [https://en.wikipedia.org /wiki/Hebrew_alphabet of the Hebrew language alphabet] which I numbered the relevant characters from 1 to 21.

In the Charinsert the following pairs of characters appear in the wrong position:

11 and 12
14 and 15
16 and 17
20 and 21

need to be reversed.
Comment 1 ineuw 2014-06-08 19:44:59 UTC
Please include in the character reversal, numbers 22 and 23. I forgot to include these and didn't number them.

Thanks.
Comment 2 Amir E. Aharoni 2014-06-09 09:38:42 UTC
On which site do you see this exactly? In which skin?

CharInsert hasn't really been updated in a long while, and I cannot reproduce this anywhere, so I'm not sure that I understand what does this bug refer to.
Comment 3 ineuw 2014-06-09 17:14:15 UTC
Please look at the bottom of the attached image where I included the current Hebrew character placements of Charinsert. The upper (correct) image is from Wikipedia which I included and numbered for reference.

The bug refers to the Charinsert's incorrect placement of ALL five end (sofit) characters which should follow the regular characters (in the right to left character order):

Chaf sofit precedes Chaf,
Mem sofit precedes Mem,
Nun sofit precedes Nun,
Peh sofit precedes Peh 
Tzadik sofit precedes Tzadik 

In both en. Wikipedia and en. Wikisource I am using the Modern skin and have the same issue.

mw version 1.24wmf7 (b8870ae).

Charinsert doesn't list a version number.
Comment 4 ineuw 2014-06-09 17:17:40 UTC
Created attachment 15604 [details]
Showing the incorrect order of hebrew characters feom Charinsert
Comment 5 Amir E. Aharoni 2014-06-10 06:35:20 UTC
It's not the CharInsert extension, but the charinsert gadget: https://en.wikisource.org/wiki/MediaWiki:Gadget-charinsert.js . It should be fixed by the local gadget developers.
Comment 6 Amir E. Aharoni 2014-06-10 07:01:57 UTC
I resolved it in the English Wikipedia.
Comment 7 ineuw 2014-06-10 17:38:52 UTC
Thanks for the info. I shall deal with it locally.
Comment 8 Andre Klapper 2014-06-10 20:13:39 UTC
[Restoring INVALID resolution as gadgets are out of scope for Bugzilla]

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links