Last modified: 2014-11-12 17:26:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 65160 - image style from typography refresh was not implemented
image style from typography refresh was not implemented
Status: NEW
Product: MediaWiki skins
Classification: Unclassified
Vector (Other open bugs)
unspecified
All All
: Normal enhancement
: ---
Assigned To: Nobody - You can work on this!
https://gerrit.wikimedia.org/r/#/c/13...
:
Depends on:
Blocks: typography-refresh
  Show dependency treegraph
 
Reported: 2014-05-10 21:34 UTC by Jared Zimmerman (WMF)
Modified: 2014-11-12 17:26 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
image styling (485.11 KB, image/png)
2014-05-10 21:39 UTC, Jared Zimmerman (WMF)
Details

Description Jared Zimmerman (WMF) 2014-05-10 21:34:56 UTC

    
Comment 1 Jared Zimmerman (WMF) 2014-05-10 21:39:53 UTC
Created attachment 15342 [details]
image styling

simplified image styling in typography refresh beta feature, was not included in the stable release as it was not deemed to be "typography" however there was broad community consensus that this was an uncontroversial change, and was met with generally positive comments. 

styling includes, removal of border, and and background color, as well as small type size adjustment and increased whitespace around images for greater readability of the the caption text and differentiation from body text.
Comment 2 Gerrit Notification Bot 2014-05-10 21:53:56 UTC
Change 123815 had a related patch set uploaded by Jaredzimmerman:
Simplify thumbnail styling to have consistency with mobile implementation 

https://gerrit.wikimedia.org/r/123815
Comment 3 Andre Klapper 2014-05-11 10:36:58 UTC
(In reply to Jared Zimmerman (WMF) from comment #1)
> simplified image styling in typography refresh beta feature, was not
> included in the stable release

What "stable release"?
Comment 4 Jared Zimmerman (WMF) 2014-05-11 10:43:15 UTC
Andre, when typography refresh was integrated into vector
Comment 5 Gerrit Notification Bot 2014-05-11 15:15:17 UTC
Change 123815 merged by jenkins-bot:
Simplify thumbnail styling to have consistency with mobile implementation

https://gerrit.wikimedia.org/r/123815
Comment 6 Tomasz W. Kozlowski 2014-05-13 21:22:35 UTC
This has now been merged. 

The patch will be deployed to the production cluster with MediaWiki 1.23wmf5, so will hit MediaWiki.org on Thursday, May 15, non-Wikipedia wikis on Tuesday, May 20, and all Wikipedias on May 22.

The change will be advertised in the upcoming issue of Tech News: <https://meta.wikimedia.org/wiki/Tech/News/2014/21>
Comment 7 Bartosz Dziewoński 2014-05-13 23:04:42 UTC
Temporarily reverted in If1d7ba81b47b9351427111a9060ea9893c87c96e.
Comment 8 Jared Zimmerman (WMF) 2014-05-13 23:29:04 UTC
Bartosz do you have a fix for the issue?
Comment 9 Gerrit Notification Bot 2014-05-14 19:13:47 UTC
Change 133301 had a related patch set uploaded by Jforrester:
[Reapply] Simplify thumbnail styling to have consistency with mobile

https://gerrit.wikimedia.org/r/133301
Comment 10 Bartosz Dziewoński 2014-05-15 20:07:44 UTC
(In reply to Jared Zimmerman (WMF) from comment #8)
> Bartosz do you have a fix for the issue?

I haven't looked into this, I think Jon or Juliusz was going to do it.
Comment 11 Jared Zimmerman (WMF) 2014-05-15 20:29:35 UTC
@Bartosz, If you have any familiarity with the templates in play, it would be much appreciated if you could look into it based on the patch as proposed.
Comment 12 Bartosz Dziewoński 2014-05-16 18:44:19 UTC
Sorry, I don't really edit en.wp, I don't even know what the issue is exactly :)
Comment 13 Jared Zimmerman (WMF) 2014-05-19 18:07:11 UTC
updated gerrit link
Comment 14 Andre Klapper 2014-08-17 11:29:58 UTC
Status: Patch in https://gerrit.wikimedia.org/r/#/c/133301/ has two -1.
Comment 15 Gerrit Notification Bot 2014-08-30 21:48:44 UTC
Change 133301 abandoned by Jforrester:
[Reapply] Simplify thumbnail styling to have consistency with mobile

Reason:
In the wrong repo now. Whoever is taking this over, please do so in the Vector repo.

https://gerrit.wikimedia.org/r/133301
Comment 16 Andre Klapper 2014-11-12 15:19:50 UTC
All patches mentioned in this report were merged or abandoned - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?
Comment 17 Erwin Dokter 2014-11-12 17:26:35 UTC
This isn't entirely uncontroversial (as claimed) judging from the Typograpy Refresh feedback. Perhaps this is better suited for Winter?

Reset to NEW for now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links