Last modified: 2014-05-17 08:56:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 63972 - Remove the "Printable version" link in sidebar and the &printable=yes functionality
Remove the "Printable version" link in sidebar and the &printable=yes functio...
Status: RESOLVED DUPLICATE of bug 22256
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.24rc
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-15 22:09 UTC by Jared Zimmerman (WMF)
Modified: 2014-05-17 08:56 UTC (History)
21 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jared Zimmerman (WMF) 2014-04-15 22:09:13 UTC
Why does this have to be an explicit user action rather than invoking a print.css file when pages are printed?
Comment 1 Bartosz Dziewoński 2014-04-15 22:41:40 UTC
Just printing pages already works. (In fact, the "printable version" functions
by applying the same stylesheets that are normally used for printable media for screen media as well.)

As for the link in sidebar and the &printable=yes functionality, last time I asked the reasoning was:

* It will be necessary to actually print pages if we ever explore something
  like MobileFrontend's dynamic section loading on desktop, or dynamic loading
  of images
* People are used to having a "printable version", even if it doesn't do
  anything
* It provides support for ancient browsers that do not support CSS media
  queries, including Firefox 5 and lower

See https://en.wikipedia.org/wiki/Help:Printable for more information.
(Pity we don't have a page like this on mediawiki.org.)

Some vaguely related bugs: bug 56786, bug 39117, bug 48234. I'm copying people
who particulated in discussions there.
Comment 2 Bartosz Dziewoński 2014-04-15 22:47:35 UTC
(The link was originally added in 2005 as a result of bug 1577.)
Comment 3 Jared Zimmerman (WMF) 2014-04-15 22:57:15 UTC
Sounds like it might make sense to do something like gmail's Print email function, which would load the print.css, expand and load images, and then trigger the browser's print dialog. This would be a much smoother flow of the uses and we'd be able to make this more actionable "Print" rather than Printable version. Does that sound reasonable?
Comment 4 Bawolff (Brian Wolff) 2014-04-15 23:35:40 UTC
> * People are used to having a "printable version", even if it doesn't do
>   anything
> * It provides support for ancient browsers that do not support CSS media
>   queries, including Firefox 5 and lower

I think you can go more ancient than that - netscape 6 supports them, which means any version of firefox ever should support (i think).
Comment 5 Jon 2014-04-15 23:58:08 UTC
Yeh I think this is unnecessary code that we should be moving away from.
At the very least if people still want this feature it should be made into an optional extension.

Long live the web!!
Comment 6 MZMcBride 2014-04-16 03:09:26 UTC
(In reply to Jon from comment #5)
> Yeh I think this is unnecessary code that we should be moving away from.
> At the very least if people still want this feature it should be made into
> an optional extension.

I feel like this came up within the past year. The wikitech-l mailing list or Bugzilla may have additional discussion. I'd also recommend reading bug 22256 if you haven't already. I seem to remember feeling similarly, but then I decided to ultimately not advocate for removal.

> Long live the web!!

Let's please remember that paper has a much longer and proven shelf life than floppy disks, CDs, DVDs, and the hard drive in your computer. It also doesn't require electricity. No hating on print, please.
Comment 7 MZMcBride 2014-04-16 03:13:59 UTC
(In reply to MZMcBride from comment #6)
> I seem to remember feeling similarly, but then I decided to ultimately not
> advocate for removal.

Bug 56875, of course. This bug seems to be a duplicate.
Comment 8 Jon 2014-04-16 04:19:31 UTC
I'm not hating on print. I hate older browsers and that do not support print media queries and am advocating the use of those instead of an action=print

This is what file-> print is for
Comment 9 Jon 2014-04-16 04:20:00 UTC
(long live the web!)
Comment 10 Nemo 2014-05-17 08:56:48 UTC
(In reply to MZMcBride from comment #7)
> (In reply to MZMcBride from comment #6)
> > I seem to remember feeling similarly, but then I decided to ultimately not
> > advocate for removal.
> 
> Bug 56875, of course. This bug seems to be a duplicate.

Indeed; bug 22256 is clearer and more compelling.

*** This bug has been marked as a duplicate of bug 22256 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links