Last modified: 2014-04-10 23:03:46 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 63686 - Effective font size is lower in Firefox/Iceweasel after typography refresh
Effective font size is lower in Firefox/Iceweasel after typography refresh
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: typography-refresh
  Show dependency treegraph
 
Reported: 2014-04-08 17:36 UTC by Matthew Flaschen
Modified: 2014-04-10 23:03 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
English WIkipedia screenshot showing old fonts (2013-08-02) (253.63 KB, image/png)
2014-04-08 17:37 UTC, Matthew Flaschen
Details
English WIkipedia screenshot showing new fonts with smaller effective size (2014-04-08) (252.68 KB, image/png)
2014-04-08 17:42 UTC, Matthew Flaschen
Details

Description Matthew Flaschen 2014-04-08 17:36:03 UTC
On my system, with Iceweasel (Firefox) 24.3.0, the effective body font size decreased.  This appears to be due to the change in effective body font from DejaVu Sans to Nimbus Sans L.  It seems the font family change means it's actually smaller despite the slight em bump.

I'm not sure what a feasible solution to this is, but I'm putting it here for tracking.

I'll attach screenshots from English Wikipedia, but the issue is also present in core (I compared wmf/1.23wmf19 to master (768c1872435a94ec936c982dd72cb0074b7ea6fc to verify it was present in core itself).
Comment 1 Matthew Flaschen 2014-04-08 17:37:13 UTC
Created attachment 15052 [details]
English WIkipedia screenshot showing old fonts (2013-08-02)
Comment 2 Matthew Flaschen 2014-04-08 17:42:29 UTC
Created attachment 15053 [details]
English WIkipedia screenshot showing new fonts with smaller effective size (2014-04-08)
Comment 3 Steven Walling 2014-04-08 17:58:47 UTC
Yes, Nimbus is the intended new font here.  

The tradeoffs here are not obvious I think. Nimbus might end up a bit smaller, but the x-height is improved, which may on balance improve readability. 

I'd be interested to see what the Chrome experience is too, since on Linux they tend to render slightly differently.

Jared, thoughts?
Comment 4 Jared Zimmerman (WMF) 2014-04-08 18:36:49 UTC
subjectively I think the Nimbus font is easier to read because of the greater difference i x-height to ascender height.
Comment 5 Steven Walling 2014-04-10 23:03:46 UTC
Per Jared's agreement that the advantage of Nimbus's improved x-height is worth it.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links