Last modified: 2014-09-16 23:57:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 61886 - Document in style guide how to use mw-ui-button on wiki using mw-ui-button span inside an anchor
Document in style guide how to use mw-ui-button on wiki using mw-ui-button sp...
Status: RESOLVED DUPLICATE of bug 48184
Product: MediaWiki
Classification: Unclassified
MediaWiki UI (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
https://www.mediawiki.org/wiki/MediaW...
:
: 63275 (view as bug list)
Depends on:
Blocks: documentation
  Show dependency treegraph
 
Reported: 2014-02-25 01:55 UTC by spage
Modified: 2014-09-16 23:57 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description spage 2014-02-25 01:55:20 UTC
Pages and templates wrap hyperlinks with span tags to make buttons, see URL above and e.g. https://en.wikipedia.org/wiki/Template:Blue_button and https://commons.wikimedia.org/wiki/Template:Clickable_button

This doesn't work with mw-ui-button mw-ui-progressive. The hyperlink styling in skins/common/commonElements.css 
  a { color: #0645ad; }
and the browser's handling of visited/unvisited hy win out over the surrounding Agora styling.

Perhaps mediawiki.ui.button should apply styles to <a> tags within.  Or pages can put spans inside links, so instead of
  <span class="mw-ui-button mw-ui-progressive mw-ui-big">[[Download|Get MediaWiki]]</span>
use
  [[Download|<span class="mw-ui-button mw-ui-progressive mw-ui-big">Get MediaWiki</span>]]

If the latter works reliably then this bug can be WONTFIX.

In generated HTML we specifying classes directly on the link, i.e. <a href class="mw-ui-...">, but there are bugs with that too, e.g. bug 48184.
Comment 1 Bartosz Dziewoński 2014-02-25 02:00:45 UTC
(In reply to spage from comment #0)
> Perhaps mediawiki.ui.button should apply styles to <a> tags within.  Or
> pages can put spans inside links, so instead of
>   <span class="mw-ui-button mw-ui-progressive mw-ui-big">[[Download|Get
> MediaWiki]]</span>
> use
>   [[Download|<span class="mw-ui-button mw-ui-progressive mw-ui-big">Get
> MediaWiki</span>]]
> 
> If the latter works reliably then this bug can be WONTFIX.

The latter should always work, even on silly old browsers. We should, however, explicitly document (and support) that people should use a <span> here, never a <div>, otherwise Tidy will destroy the HTML (that's I think bug 9737 in particular and bug 2542 in general).
Comment 2 Bartosz Dziewoński 2014-02-25 02:02:18 UTC
(I agree with the WONTFIX proposal, trying to support the format syntax looks like a nasty hack to me.)
Comment 3 Matthew Flaschen 2014-02-25 22:55:49 UTC
I'm changing this to a doc bug.  We should add examples to http://tools.wmflabs.org/styleguide/desktop/section-2.html explicitly noting it's for on-wiki markup (i.e. the span method).
Comment 4 Matthew Flaschen 2014-03-31 22:14:22 UTC
*** Bug 63275 has been marked as a duplicate of this bug. ***
Comment 5 Jon 2014-08-28 18:56:32 UTC
So.. what is the bug here? Can some
Comment 6 Jon 2014-09-16 23:57:40 UTC
There's a lot of overlap with bug 48184 so let's collapse this into one bug for clarity.

*** This bug has been marked as a duplicate of bug 48184 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links