Last modified: 2013-12-23 19:29:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 52974 - "Enter your username" placeholder text on signup page
"Enter your username" placeholder text on signup page
Status: RESOLVED DUPLICATE of bug 43172
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
1.22.0
All All
: Low minor (vote)
: ---
Assigned To: Nobody - You can work on this!
: easy
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 01:23 UTC by John Mark Vandenberg
Modified: 2013-12-23 19:29 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description John Mark Vandenberg 2013-08-18 01:23:46 UTC
The placeholder text "Enter your username" is not appropriate when the person does not yet have a username (type=signup).

The placeholder text "Enter a password"/"Enter your password" has been customised for type=signup ; the same should be done for the username field.
Comment 1 John Mark Vandenberg 2013-08-18 01:38:57 UTC
Hmm. The following page suggests the form placeholder text "Enter a desired username" was used.

http://www.mediawiki.org/wiki/Account_creation_user_experience/Strings/Experiment

I've tested on a few other wmf wikis and they all have "Enter your username" on type=signup.
Comment 2 Steven Walling 2013-08-18 02:42:56 UTC
(In reply to comment #0)
> The placeholder text "Enter your username" is not appropriate when the person
> does not yet have a username (type=signup).
> 
> The placeholder text "Enter a password"/"Enter your password" has been
> customised for type=signup ; the same should be done for the username field.

Enter your *desired* username is implied I think, since the person obviously knows they're creating an account. We moved away from not using possessives (e.g. "a username" vs. "your username") because it needs to be clear that we're talking about something that represents your identity on the given project. 

The strings page you link to was part of an A/B test and wasn't the final spec, hence the /Experiment name. Sorry for any confusion.
Comment 3 Tony Thomas 2013-12-07 18:26:10 UTC
How about Enter Username: ?
Comment 4 Bartosz Dziewoński 2013-12-23 19:29:58 UTC
This has been fixed for some time as part of bug 43172.

*** This bug has been marked as a duplicate of bug 43172 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links