Last modified: 2013-12-23 19:29:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 43172 - Reword some messages on account creation interface for logged in users
Reword some messages on account creation interface for logged in users
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.21.x
All All
: Normal normal (vote)
: ---
Assigned To: spage
:
: 47792 52974 (view as bug list)
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2012-12-16 16:45 UTC by Liangent
Modified: 2013-12-23 19:29 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Liangent 2012-12-16 16:45:17 UTC
* Already have an account? Log in.

It's already known the operator has an account and this page is deliberately visited. Just hide this line?

* E-mail address is optional, but is needed for password resets, should you forget your password. You can also choose to let others contact you by e-mail through a link on your user or talk page. Your e-mail address is not revealed when other users contact you.

Various "you" are not suitable because it's usually true that the operator is creating an account for another person.

* Real name is optional. If you choose to provide it, this will be used for giving you attribution for your work.

Ditto.

* Remember my login on this browser (for a maximum of 180 days)

It's not "my login". Also this checkbox doesn't make much sense in this context.
Comment 1 Alex Monk 2012-12-22 20:14:03 UTC
Gerrit change #39862
Comment 2 Alex Monk 2013-06-22 16:50:34 UTC
Had to rewrite this for the new login form... Please take a look at patch set 9.
Comment 3 Alex Monk 2013-07-21 16:21:56 UTC
*** Bug 47792 has been marked as a duplicate of this bug. ***
Comment 4 Gerrit Notification Bot 2013-07-21 16:22:15 UTC
Change 39862 abandoned by Alex Monk:
Tweak account creation interface messages for logged in users

Reason:
See bug

https://gerrit.wikimedia.org/r/39862
Comment 5 Alex Monk 2013-07-21 16:23:35 UTC
Quietly resolved for a separate bug (now marked as dupe) with a separate commit by someone who was on my commit's reviewer list since February.
Comment 6 Gerrit Notification Bot 2013-07-23 00:45:59 UTC
Change 39862 restored by Spage:
Tweak account creation interface messages for logged in users

Reason:
There are good ideas in here that change I00e0d21d63bf32ad691ea3a27523298478e2d45c doesn't incorporate, I will submit a revision that restores them.  I didn't intend to ignore this solid gerrit change, it's my fault for confusing it with 66193.

https://gerrit.wikimedia.org/r/39862
Comment 7 Matthew Flaschen 2013-07-23 06:15:41 UTC
Sorry, Alex.  I wasn't aware of this bug, or 39862.  I've added myself as reviewer to the change now.
Comment 8 Gerrit Notification Bot 2013-08-13 14:56:04 UTC
Change 39862 merged by jenkins-bot:
Tweak login/account creation for logged in users

https://gerrit.wikimedia.org/r/39862
Comment 9 Nemo 2013-08-13 15:10:29 UTC
Thanks Krenair and MatmaRex. The worst offender for this bug is the title of Special:UserLogin/signup, MediaWiki:Createaccount .
It was originally only the title of the special page, but got recently abused as link label from the personal toolbar of unregistered users; the result is that e.g. in Italian it says "Register" to satisfy the new usecase and is no longer ok as title for the special page. The two messages should be separated.
Comment 10 Matthew Flaschen 2013-08-14 19:10:36 UTC
(In reply to comment #9)
> Thanks Krenair and MatmaRex. The worst offender for this bug is the title of
> Special:UserLogin/signup, MediaWiki:Createaccount .
> It was originally only the title of the special page, but got recently abused
> as link label from the personal toolbar of unregistered users; the result is
> that e.g. in Italian it says "Register" to satisfy the new usecase and is no
> longer ok as title for the special page. The two messages should be
> separated.

Filed as bug 52861.
Comment 11 Bartosz Dziewoński 2013-12-23 19:29:58 UTC
*** Bug 52974 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links