Last modified: 2013-10-24 16:12:11 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 52191 - Badly formatted login error when username banned from creation
Badly formatted login error when username banned from creation
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: spage
: i18n
: 54336 (view as bug list)
Depends on: 44718
Blocks: messages
  Show dependency treegraph
 
Reported: 2013-07-28 12:42 UTC by Sumana Harihareswara
Modified: 2013-10-24 16:12 UTC (History)
7 users (show)

See Also:
Web browser: Firefox
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
webpage displaying login error (93.17 KB, image/png)
2013-07-28 12:42 UTC, Sumana Harihareswara
Details
close-up of login error (74.92 KB, image/png)
2013-07-28 12:43 UTC, Sumana Harihareswara
Details
enwiki screenshot (219.88 KB, image/png)
2013-07-28 16:29 UTC, Steven Walling
Details

Description Sumana Harihareswara 2013-07-28 12:42:43 UTC
Created attachment 12992 [details]
webpage displaying login error

This might be multiple bugs that need to be split up.

I went to zh.wikipedia.org and clicked the 登录 link in the upper right hand corner (next to the user icon) to sign in.  I presumed that my user account for User:Sharihareswara_(WMF) would get me in, thanks to SUL.

I know the login UI so it didn't bother me that it was labelled in a language I don't know.  I filled in:

Username: Sharihareswara (WMF)
Password: [correct password]

and got the following error message in red (see screenshots):

登录错误
<<table id="mw-protectedpagetext" class="plainlinks fmbox fmbox-warning" style="clear: both; margin: 0.2em 0; border: 1px solid #aaa; background: #f9f9f9; width: 100%; background: #FFDBDB; border: 1px solid #BB7070;"> <tr> <td class="mbox-text" style=""> <p>本用户已经被禁止创建,由于用户名“Sharihareswara (WMF)”和<a href="/wiki/MediaWiki:Titleblacklist" title="MediaWiki:Titleblacklist">本地</a>或<a href="//meta.wikimedia.org/wiki/Title_blacklist" class="extiw" title="m:Title blacklist">全域</a>黑名單<code> .*(apologise|war).* &lt;newaccountonly&gt;</code>配合。请确保用户名符合<a href="/wiki/Wikipedia:%E7%94%A8%E6%88%B7%E5%90%8D" title="Wikipedia:用户名">用户名方针</a>。如果需要协助,请参照<a href="/wiki/Wikipedia:%E8%B4%A6%E5%8F%B7%E8%AF%B7%E6%B1%82" title="Wikipedia:账号请求">Wikipedia:账号请求</a>所列指示直接向管理员申请账号或提交反馈。 </p> </td> </tr> </table> > 

When I switched to English via the ":中文(简体)‎ | 中文(繁體)‎ | English | 日本語 | 한국어" choices just above that error and tried again, I got:


Login error
<The user name "Sharihareswara (WMF)" has been banned from creation. It matches the following blacklist entry: <code> .*(apologise|war).* &lt;newaccountonly&gt;</code>> 


(My last name has the string "war" in it; never realized that before.)

However, if I tried logging in with an *incorrect* password, I got a well-formatted error "Login error: Incorrect password entered. Please try again." or "登录错误: 你输入的密码错误。请重试".  That error message doesn't reveal any of the <table> or <code> tags to the user in the message.

Therefore:

1) Zhwiki administrators or Chinese translators, could you fix the messaging for the "this username has been banned from creation"?  I looked in https://translatewiki.net/w/i.php?title=Special:Translate&language=zh-hant&group=core&filter=&action=translate and I couldn't figure out what message needs fixing, sorry.

2) If the wiki's administrators have banned a particular user name from creation, but our SUL unification tries to make an account for them, then is it the right thing to do to still display a regular "wrong password" error message when someone tries to login with that username but gets the password wrong?
Comment 1 Sumana Harihareswara 2013-07-28 12:43:10 UTC
Created attachment 12993 [details]
close-up of login error
Comment 2 Liangent 2013-07-28 12:58:53 UTC
(1) is a due to bug 44718.
(2) is a real bug, but more or less related to bug 36939.
Comment 3 Liangent 2013-07-28 13:02:04 UTC
For that specific blacklist rule, I edited it to make it match word boundaries only[1], so Sumana you should be able to log in now.

[1] https://zh.wikipedia.org/w/index.php?title=MediaWiki:Titleblacklist&diff=27947386&oldid=27399854
Comment 4 Steven Walling 2013-07-28 16:29:48 UTC
Created attachment 12994 [details]
enwiki screenshot
Comment 5 Steven Walling 2013-07-28 16:33:38 UTC
This kind of error is also present on enwiki, it seems. Thought it might be related more to 44718. Not sure. 

I've added S Page to the bug, the engineer who did the bulk of our team's work on account creation. He should be able to help hunt down what's going on here.
Comment 6 Liangent 2013-09-20 12:31:15 UTC
*** Bug 54336 has been marked as a duplicate of this bug. ***
Comment 7 Gerrit Notification Bot 2013-09-25 17:03:16 UTC
Change 47821 had a related patch set uploaded by Bartosz Dziewoński:
Fix double-parsing of account creation messages.

https://gerrit.wikimedia.org/r/47821
Comment 8 Gerrit Notification Bot 2013-10-24 10:35:36 UTC
Change 47821 merged by jenkins-bot:
Fix double-parsing of account creation messages.

https://gerrit.wikimedia.org/r/47821

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links