Last modified: 2013-07-25 07:08:11 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 50196 - In RTL languages, "history" and "add section" menu items moved into the hidden menu
In RTL languages, "history" and "add section" menu items moved into the hidde...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
JavaScript (Other open bugs)
1.22.0
All All
: Highest critical (vote)
: ---
Assigned To: Alex Monk
:
Depends on:
Blocks: rtl wmf-deployment
  Show dependency treegraph
 
Reported: 2013-06-25 20:20 UTC by kipod
Modified: 2013-07-25 07:08 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description kipod 2013-06-25 20:20:52 UTC
(by "the hidden menu" i mean the menu that opens under the inverted triangle - where "move" normally lives). with wmf8, "history" and "add section" moved there also. i do not believe this is intentional - this does not seem to happen in ltr wikis, and was not announce anywhere.

i am 88.21% certain this is a result of bug 50193, but i can't be 100% sure.
the problem goes away if you disable javascript.

peace.
Comment 1 kipod 2013-06-25 21:54:38 UTC
ok. this is not related to  bug 50193, but rather to something else in collapsibleTabs.js:

the problem is that collapsibleTabs.js has a "module global" variable named "rtl", which is calculated on startup by calling 

var rtl = $( 'body' ).is( '.rtl' );

the problem is that this module is loaded too early, and at this point in time, 

$( 'body' ).is( '.rtl' )

returns false, even though it *is* and RTL wiki.

we should postpone the calculation of this variable to a later time: e.g., inside $.fn.collapsibleTabs(), do something like

if ( typeof rtl === "undefined" )
    rtl = $( 'body' ).is( '.rtl' );

also, if this code is exactly equal to upstream, methinks we should report the issue there too.

peace.
Comment 2 Gerrit Notification Bot 2013-06-25 23:46:12 UTC
Related URL: https://gerrit.wikimedia.org/r/70569 (Gerrit Change I6e277a9503a1e6003bc7bf9f9468ed7b35552e60)
Comment 3 Bartosz Dziewoński 2013-06-26 00:09:43 UTC
(The module is now loaded from the 'top' queue, while it was loaded from 'bottom' before when it was a part of the Vector extension instead of core.)
Comment 4 kipod 2013-06-26 00:27:49 UTC
based on my tests, this patch solves the problem. (tested with chrome).

please try to merge this patch before wmf8 is deployed to RTL wikipedias (June 27, according to the roadmap) - i can hear my users screaming "where is my history tab, where is my add section tab" all the way up to here (they are already screaming on wiktionary...)

Thanks!

peace.
Comment 5 Gerrit Notification Bot 2013-06-26 01:19:07 UTC
Related URL: https://gerrit.wikimedia.org/r/70576 (Gerrit Change I6e277a9503a1e6003bc7bf9f9468ed7b35552e60)
Comment 6 Alex Monk 2013-06-26 01:24:36 UTC
Merged by Roan, looks like he's deploying it now.
Comment 7 Alex Monk 2013-06-26 01:43:17 UTC
It was deployed:
<logmsgbot> !log catrope synchronized php-1.22wmf8/skins/vector/collapsibleTabs.js  'I6e277a9503a1e6003bc7bf9f9468ed7b35552e60'
And is working: https://www.mediawiki.org/wiki/Talk:MediaWiki?uselang=ar
Comment 8 Bartosz Dziewoński 2013-06-26 01:43:50 UTC
Fixed, deployed, verified, works. Sorry about the trouble! :)
Comment 9 kipod 2013-06-26 04:47:57 UTC
thanks! this was quick.

peace.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links