Last modified: 2013-10-29 05:17:52 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 49932 - Shift the ULS icon to header and label it
Shift the ULS icon to header and label it
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
UniversalLanguageSelector (Other open bugs)
unspecified
All All
: Unprioritized enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 49560 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 05:48 UTC by Ravishankar
Modified: 2013-10-29 05:17 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ravishankar 2013-06-21 05:48:54 UTC
Hi, 

After the Narayam extension has been replaced by ULS, even regular users are finding it difficult to locate the typing tool and it is definitely not intuitive for a new comer.

The left side panel is for navigation and a setting should not be clubbed there. Users usually look for settings in the top right corner of a site. At least it should be near  the preferences link in  the header. 

The icon gives no clue about its use unless it is clicked and seen. The icon should be clearly labelled as "Language / typing / font settings".

I read elsewhere that this extension has been rolled out after user testing and it works for the developer. 

But the language communities that use this tool never had a chance to test, there was no beta rollout, there was no announcement or request for feedback. The tool might have worked as such for the commons community but shifting the location for other communities has made it confusing. 

Why can't the icon be moved to the top for all languages as you do in Commons?
Comment 1 Nemo 2013-06-21 06:56:03 UTC
(In reply to comment #0)
> But the language communities that use this tool never had a chance to test,
> there was no beta rollout, there was no announcement or request for feedback.

False, false and false. :) Check better your village pumps for announcements and beta.wmflabs.org. But sure, little help testing came from the ta.wiki community, it's true that the announcements are not very effective; they're constantly trying to get better.

> The tool might have worked as such for the commons community but shifting the
> location for other communities has made it confusing. 
> 
> Why can't the icon be moved to the top for all languages as you do in
> Commons?

I don't know about "can't", but is this your opinion or a consensual wish of the community?
There's an explanation at <https://www.mediawiki.org/wiki/Universal_Language_Selector/Testing#Location_for_the_Selector>, I've added a link from the FAQ.
Comment 2 Nemo 2013-06-21 07:04:58 UTC
*** Bug 49560 has been marked as a duplicate of this bug. ***
Comment 3 Siebrand Mazeland 2013-06-21 07:14:04 UTC
Thank you for your input. We have tested this, and things are discoverable. The previous UI was too present. At this point in time, we are not considering a change. I'm closing this change request as WONTFIX.
Comment 4 Ravishankar 2013-06-21 07:46:31 UTC
Nemo, 

I only found an announcement prior to rollout in Village pump that Narayam and web fonts will be replaced by ULS:

https://ta.wikipedia.org/wiki/%E0%AE%B5%E0%AE%BF%E0%AE%95%E0%AF%8D%E0%AE%95%E0%AE%BF%E0%AE%AA%E0%AF%8D%E0%AE%AA%E0%AF%80%E0%AE%9F%E0%AE%BF%E0%AE%AF%E0%AE%BE:%E0%AE%86%E0%AE%B2%E0%AE%AE%E0%AE%B0%E0%AE%A4%E0%AF%8D%E0%AE%A4%E0%AE%9F%E0%AE%BF#Universal_Language_Selector_to_replace_Narayam_and_WebFonts_extensions

It didn't invite for testing and still there is no beta rollout.  It was not clear that web fonts will be forced on communities that didn't want it. As you said the it's true that the announcements are not very effective. Otherwise, the community has no reason to be agitated when things are rolled out. 

Thanks for the link regardin ULS icon location.

Siebrand,

I don't understand the problem with being "too present". The earlier Narayam tool's location was intuitive even for new users. Now, people are searching for the hidden icon. 

The test result 

//Using two different locations for language-related settings creates confusion.//

is wrong by test design itself. 

When Narayam was there, the interlanguage links and typing tool were at different locations  and it didn't cause any confusion at all. This is real time community feedback which is more valid than the feedback provideb by the testing users. 

Other language link is a navigational aid and language setting is a control aid. Just because both have the keyword language, they don't need to be clubbed. In fact, most of the normal users don't visit other language Wikis. But, regular users do use the typing tool a lot. Now you have clubbed the most used typing tool with a least used other language link. 

Also, all the wiki's interface language are by default in the local language and there is only a rare need for people to switch it. 

By combining different use cases, things have been made more difficult.

The test result

//Integration with interlanguage links (Option B) works. It works great especially for content and UI changes. //

is not so valid for content and UI changes. Regular users look to activate a typing tool before they touch the input box. When there is no such clue, they hesitate to try the input box at all and discover that a typing aid is presented later.

Following results from the test results are valid and present the point I make:
//Users perceived the top-right zone as a settings area.//

//The Cog icon, was considered not to attract the attention as the previous one but to better convey the meaning of "settings".//

But, it is unfortunate that the design team has made a wrong conclusion from the results. 

Leave the interlanguage links and langauge settings separate and at the right locations. There is no need to club them together. 

Even if you are not going to fix this issue, let me register these points. 

Thanks.
Comment 5 Andre Klapper 2013-06-21 07:49:19 UTC
Please do not reopen bug reports as a sign of disagreement. Thanks.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links