Last modified: 2013-10-29 05:11:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 49560 - ULS icon is too small and unidentifiable
ULS icon is too small and unidentifiable
Status: RESOLVED DUPLICATE of bug 49932
Product: MediaWiki extensions
Classification: Unclassified
UniversalLanguageSelector (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: design
Depends on:
Blocks: 56295
  Show dependency treegraph
 
Reported: 2013-06-14 02:14 UTC by praveenp
Modified: 2013-10-29 05:11 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Page on My 1400 x 900 monitor (281.43 KB, image/jpeg)
2013-06-14 02:14 UTC, praveenp
Details
Still where is it? Just to prove a point (308.82 KB, image/jpeg)
2013-06-14 02:16 UTC, praveenp
Details

Description praveenp 2013-06-14 02:14:57 UTC
Created attachment 12536 [details]
Page on My 1400 x 900 monitor

ULS icon is too small and unidentifiable. It is hard to find and customize. Moreover, default font forced on Malayalam language wiki projects is too small in Windows (OS) and makes the page ugly (someone mentioned it as a cow dung pit :-)). This increases the usability problems of the extension.

Please make it simillar to other wikies (commons, translatewiki etc)
Comment 1 praveenp 2013-06-14 02:16:23 UTC
Created attachment 12537 [details]
Still where is it? Just to prove a point
Comment 2 praveenp 2013-06-14 11:05:55 UTC
Seriously? WORKSFORYOU? Did you use any of these projects? :-( Reopening (atleast for that explanation)
Comment 3 Siebrand Mazeland 2013-06-14 11:10:59 UTC
Praveen, you are trolling. Adding a screenshot with letters over the icon is not a productive use of your or my time. This works for me, and it worked in our user testing. This issue is done.
Comment 4 praveenp 2013-06-14 11:36:16 UTC
No I am not. I just shown that icon is too small. Who told you this issue is done? I doubt you even loaded any ULS enabled wiki pages except meta or commons. How someone with no idea about ULS (or even webfonts) can fix current uglyness of pages? You are just familiar with ULS and you are not a regular user, so this (may) works for you. But Why didn't you force such code on commons or meta?

I am so part of this community, I must reopen this bug. 

Please see this Tamil wikipedia discussion also: http://ta.wikipedia.org/wiki/%E0%AE%B5%E0%AE%BF%E0%AE%95%E0%AF%8D%E0%AE%95%E0%AE%BF%E0%AE%AA%E0%AF%8D%E0%AE%AA%E0%AF%80%E0%AE%9F%E0%AE%BF%E0%AE%AF%E0%AE%BE_%E0%AE%AA%E0%AF%87%E0%AE%9A%E0%AF%8D%E0%AE%9A%E0%AF%81:Request_for_Comment/Web_fonts_implementation_for_Tamil_Wikimedia_projects
Comment 5 Siebrand Mazeland 2013-06-14 11:47:55 UTC
For the record: No action will be taken on this issue. The report is being treated as Closed/Worksforme, but not actually closed anymore as the reported keeps reopening it.
Comment 6 praveenp 2013-06-14 11:56:24 UTC
Wikipedia is not a developers play ground. This system is for users (and even for anonymous users). Setting priority to normal untill someone can give a solution or even a credible answer.
Comment 7 Nemo 2013-06-14 12:15:16 UTC
You seem the one disconnected from community: they voiced different concerns, which are being addressed elsewhere.
Comment 8 Deepu G Nair 2013-06-14 13:59:31 UTC
(In reply to comment #7)
> You seem the one disconnected from community: they voiced different concerns,
> which are being addressed elsewhere.


Hes  not the one alone, there are other users like me concerned.

ULS is definitely buggy and some serious bugs were fixed after putting it to use in commons.
Comment 9 Andre Klapper 2013-06-14 14:20:59 UTC
For future reference, please only file one problem per bug report (the initial comment mentions both criticism on the UI and a default font for Malayalam. Also see https://www.mediawiki.org/wiki/How_to_report_a_bug for general information.

There is no software without any issues out there that I am aware of (what individuals consider "bugs" is discussable, so I say "issues") and there will never be software that perfectly fits the expectations of really everybody.
Saying this, it would probably be helpful if results of user testing were available somewhere, and to not simply close bug reports as WORKSFORME without any explanation to the reporter providing feedback.

Wikipedia is not and has not been a "developers playground" as user testing has taken place. As far as I know its result was to keep the ULS icon at the top for cross-language sites while moving it to the "Languages" area in the sidebar for single-language sites with different input methods.

Hence there are currently no plans to change the current design, which does not mean that this result might not be reevaluated at some point in the future if there are new findings or other changes in the setup/surroundings.
Comment 10 vssun 2013-06-14 15:40:50 UTC
It may also be noted that the icon doen't convey the idea that it is something related to languages. Movement of its location from top (traditional location of settings) to sidebar increases complexity for new as well as experienced users.
Comment 11 Deepu G Nair 2013-06-14 16:13:43 UTC
(In reply to comment #9)
> For future reference, please only file one problem per bug report (the
> initial
> comment mentions both criticism on the UI and a default font for Malayalam.
> Also see https://www.mediawiki.org/wiki/How_to_report_a_bug for general
> information.
> 
> There is no software without any issues out there that I am aware of (what
> individuals consider "bugs" is discussable, so I say "issues") and there will
> never be software that perfectly fits the expectations of really everybody.
> Saying this, it would probably be helpful if results of user testing were
> available somewhere, and to not simply close bug reports as WORKSFORME
> without
> any explanation to the reporter providing feedback.
> 
> Wikipedia is not and has not been a "developers playground" as user testing
> has
> taken place. As far as I know its result was to keep the ULS icon at the top
> for cross-language sites while moving it to the "Languages" area in the
> sidebar
> for single-language sites with different input methods.
> 
> Hence there are currently no plans to change the current design, which does
> not
> mean that this result might not be reevaluated at some point in the future if
> there are new findings or other changes in the setup/surroundings.


Hi Andre,

Thanks for your reply, let me make clear that the ULS icon is not the main issue. ULS was buggy when it was put in commons, 

The preferences were not getting saved until the page was refreshed. Changing the input methods was one of the main features of ULS and that was not working when implemented in commons initially, how ridiculous.

Hope you can think how a common user would feel when he changed his preferences and seeing it is not applied, defenitely it is a bug and a very serious one.

I definitely understand and agree to your point that there are not softwares without issues, but to find a software which dont serve the purpose it was made for is very rare and i found one in the initial implementation of ULS in commons. 

We had a discussion among admins in malayalam wikipedia and even withdrew ULS implementation request from malayalam wikisource since the admins were convinced that ULS was buggy at that time.
Comment 12 ansuman 2013-06-17 01:29:13 UTC
Yes, it's a serious issue for new users. There is no way they'd find out about the update by themselves especially people not active around Meta, mailing list, and community notification. Yes there are such users. At the least please add a link to the personal toolbar about this update with detailed instructions (to meta) how to use it. So they'd understand.

And I think default fonts and input methods are not suitable for many users at different Indian language Wikipedias. Any solution?
Comment 13 ansuman 2013-06-17 07:46:08 UTC
And I must add, unlike Commons and Meta, why it's taking 3-4 seconds to appear the Language settings (pop up) option at sidebar??
Comment 14 Andre Klapper 2013-06-18 01:01:17 UTC
ansuman: This bug report is about the icon. Please ask other things (taking 3-4 seconds to appear) somewhere else (e.g. https://www.mediawiki.org/wiki/Talk:Universal_Language_Selector ) and keep this focused. Thanks.
Comment 15 ansuman 2013-06-18 06:55:44 UTC
Andre: Thanks. I know, i wanted to do that too. Since the issues were being discussed here, i have mentioned. Sorry for the disruption.
Comment 16 Ravishankar 2013-06-21 06:54:15 UTC
This is a genuine issue and even regular contributors found it confusing and hard to locate the icon and its purpose. We had to publish help guides in the site notice to get this issue under control in Tamil Wikipedia. 

Please check

https://bugzilla.wikimedia.org/show_bug.cgi?id=49932

Shifting the icon to the top and labelling it properly will help.
Comment 17 Nemo 2013-06-21 07:04:58 UTC
You have already asked this in the other bug; this one has comments on too many different topics, that one is about a specific suggestion: you can continue there.

*** This bug has been marked as a duplicate of bug 49932 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links