Last modified: 2014-02-03 20:10:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 46594 - PostgreSQL syntax error: LOCK IN SHARE MODE when running Category
PostgreSQL syntax error: LOCK IN SHARE MODE when running Category
Status: RESOLVED DUPLICATE of bug 39635
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.22.0
All All
: Normal normal (vote)
: 1.22.x release
Assigned To: Nobody - You can work on this!
: patch, patch-reviewed
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2013-03-27 09:45 UTC by Seong-ho Cho
Modified: 2014-02-03 20:10 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
This patch is for getting rid of "LOCK IN SHARE MODE" related warning message. (603 bytes, patch)
2013-03-27 09:45 UTC, Seong-ho Cho
Details

Description Seong-ho Cho 2013-03-27 09:45:38 UTC
Created attachment 11992 [details]
This patch is for getting rid of "LOCK IN SHARE MODE" related warning message.

Warning: pg_query() [function.pg-query]: Query failed: ERROR: syntax error at or near "LOCK" LINE 1: ... in ${MEDIAWIKI_HOME}/includes/db/DatabasePostgres.php on line 254 when category page is called.

as below commit message
https://gerrit.wikimedia.org/r/#/c/53554/
"LOCK IN SHARE MODE" is a MySQL extension not supported by another SQL Engine.

so I suggest very simple patch for eliminating this issue.
Comment 1 Andre Klapper 2013-03-27 10:06:29 UTC
Hi Seong-ho! Thanks for your patch!

You are welcome to use Developer access
  https://www.mediawiki.org/wiki/Developer_access
to submit this as a Git branch directly into Gerrit:
  https://www.mediawiki.org/wiki/Git/Tutorial

Putting your branch in Git makes it easier to review it quickly.
Thanks again! We appreciate your contribution.
Comment 2 Marcin Cieślak 2013-07-17 15:12:43 UTC
I think PostgreSQL has "FOR SHARE" SELECT option. By then, issues listed in bug 47055 apply.
Comment 3 Merlijn van Deen (test) 2013-10-15 20:44:09 UTC
Hi Seong-ho Cho,

I tried to apply your patch, but unfortunately it did not apply cleanly. To submit a patch, you can now also use the on-line patch uploader at https://tools.wmflabs.org/gerrit-patch-uploader/ . Of course, you can also submit it directly using git.
Comment 4 Nemo 2013-12-30 09:29:17 UTC
Update per https://www.mediawiki.org/w/index.php?title=MediaWiki_1.22/Known_issues&oldid=847749 which seems to be the master list.
Comment 5 Umherirrender 2014-02-03 20:10:29 UTC
Was already fixed with bug 39635, thats why the provided patch cannot apply to current master.

*** This bug has been marked as a duplicate of bug 39635 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links