Last modified: 2013-04-09 02:39:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 46169 - "You are blocked from editing." is not appropriate for protected items.
"You are blocked from editing." is not appropriate for protected items.
Status: RESOLVED DUPLICATE of bug 45140
Product: MediaWiki extensions
Classification: Unclassified
WikidataClient (Other open bugs)
master
All All
: Low minor (vote)
: ---
Assigned To: Wikidata bugs
: easy
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2013-03-15 19:43 UTC by YFdyh000
Modified: 2013-04-09 02:39 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description YFdyh000 2013-03-15 19:43:52 UTC
Users on protected items tooltip of [edit] link will get: "You are blocked from editing.", the string seems from MediaWiki:Wikibase-blockeduser-tooltip-message.
For example http://www.wikidata.org/wiki/Q5296?uselang=en (HomePage).

This is not appropriate, the user does not have any wrong, he has not been banned.
This should apply a new string, for example: You do not have permission to edit, because the item has been protected.
And best practice is click on the link to get a dialog box, or go to a help page to illustrate a more detailed description and provide the item protection expiration time and reason.
Comment 1 Andre Klapper 2013-03-16 15:16:00 UTC
$:andre\> grep -r "blockeduser" .
./lib/resources/Resources.php:	'wikibase-blockeduser-tooltip-message',
./lib/resources/wikibase.ui.Toolbar.Button.js:
	? 'wikibase-blockeduser-tooltip-message'
./lib/resources/wikibase.ui.Toolbar.EditGroup.js:
	'wikibase-blockeduser-tooltip-message' :


Moving to "Wikibase".
Comment 2 Kunal Mehta (Legoktm) 2013-04-09 02:39:21 UTC

*** This bug has been marked as a duplicate of bug 45140 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links