Last modified: 2013-05-13 11:24:05 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 45140 - protection bubbles tell you you're blocked
protection bubbles tell you you're blocked
Status: VERIFIED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WikidataRepo (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Wikidata bugs
: need-volunteer
: 46169 (view as bug list)
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2013-02-19 00:51 UTC by T. H. Kelly (Pink&)
Modified: 2013-05-13 11:24 UTC (History)
10 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description T. H. Kelly (Pink&) 2013-02-19 00:51:14 UTC
When you try to edit an item that's been protected, you still see the "edit"/"add" buttons and have the ability to type in the text fields. While the "save" button is initially greyed out, once you start typing, it turns blue again. It's only when you try to save the change that you get the message saying the page has been protected. Seems to me it would be better to have all of the buttons just not appear, like when you're viewing an old revision, and to have the notice about the page being protected pop up in a bubble, like the one that tells you if you're editing logged out.
Comment 1 jeblad 2013-02-19 11:40:24 UTC
What kind of browser do you use? Is it possible to edit only parts of the page? Is the text boxes grayed out?
Comment 2 T. H. Kelly (Pink&) 2013-02-19 18:14:07 UTC
(In reply to comment #1)
> What kind of browser do you use?

I use Google Chrome, version 23.0.1271.111, on an Alex series Chromebook.

> Is it possible to edit only parts of the
> page?
> Is the text boxes grayed out?

Well... strangely enough, when I went to check your question, I found that the buttons were in fact all greyed out. Maybe something changed in all the updates yesterday? It's much better right now. I'd mark this as resolved, but, while we're on the topic, I notice that the text says "You are blocked from editing", when it should say that the page is protected. Try editing https://www.wikidata.org/wiki/Q16 from a non-admin account to see what I mean. (Or https://www.wikidata.org/wiki/Q5296 while logged out.)
Comment 3 jeblad 2013-02-27 00:56:11 UTC
Yes, its about the same I found and I think there is a merged changeset that made the links stay disabled.

The blocked message is a bug and should be fixed.
Comment 4 T. H. Kelly (Pink&) 2013-04-09 01:59:48 UTC
Just pinging to see where we are on this. All that needs to be changed is for a new message to show up on the tooltip instead of [[d:MediaWiki:Wikibase-blockeduser-tooltip-message]].
Comment 5 Kunal Mehta (Legoktm) 2013-04-09 02:39:21 UTC
*** Bug 46169 has been marked as a duplicate of this bug. ***
Comment 6 Jasper Deng 2013-04-11 20:44:05 UTC
https://gerrit.wikimedia.org/r/gitweb?p=mediawiki/extensions/Wikibase.git;a=commitdiff;h=384baeac31516857131553b80a5813b79588953f;hp=ac63d423b3f0fc133e5ad99a57479a561a7a30ee

The code in this commit seems to wrongly assume that the only time blockItemActions is called would be when the user is blocked, but it also seems that this is also called when the page is protected.
Comment 7 tobias.gritschacher 2013-04-15 12:12:24 UTC
https://gerrit.wikimedia.org/r/#/c/59125/

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links