Last modified: 2014-09-13 17:53:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 45144 - Load toolbar on element ready instead of content ready
Load toolbar on element ready instead of content ready
Status: RESOLVED DUPLICATE of bug 45145
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: performance
Depends on:
Blocks: edit-toolbar
  Show dependency treegraph
 
Reported: 2013-02-19 04:46 UTC by Isarra
Modified: 2014-09-13 17:53 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Isarra 2013-02-19 04:46:47 UTC
Apparently the toolbar currently loads on content ready after the entire page finishes loading. Since said entire page can take quite awhile and people often want to start editing before that and the toolbar can prevent editing until it loads, move the textarea down when it does, and otherwise mess up anyone who has already tried to start, it should really be loading as soon as the relevant stuff is ready instead of waiting for everything else too.
Comment 1 Nemo 2014-06-01 06:58:39 UTC
(In reply to Isarra from comment #0)
> page can take quite awhile and
> people often want to start editing before

In better news, TheDJ fixed most of the negative consequences of this (at least in my experience): bug 41911.
Comment 2 Bartosz Dziewoński 2014-08-20 15:54:08 UTC

*** This bug has been marked as a duplicate of bug 45145 ***
Comment 3 Isarra 2014-08-21 02:55:03 UTC
Does this use the same code as the core toolbar now?
Comment 4 Bartosz Dziewoński 2014-09-13 17:53:31 UTC
Probably not, but I think the solution in both cases would have to be the same, or very similar.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links