Last modified: 2013-04-11 00:59:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 44455 - ULS places map sections backward in RTL languages
ULS places map sections backward in RTL languages
Status: RESOLVED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
UniversalLanguageSelector (Other open bugs)
master
All All
: High major (vote)
: ---
Assigned To: Amir E. Aharoni
: i18n
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2013-01-29 02:35 UTC by Yair Rand
Modified: 2013-04-11 00:59 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Yair Rand 2013-01-29 02:35:18 UTC
The world map at the top of the ULS places the region names in the wrong places when the user has a RTL language set. In Hebrew, for example, the text "אמריקה" ("Americas") is shown on the right-hand side of the map, in the area where East Asia is shown, and clicking on it brings the user to the Americas section. Clicking on the left part, where the Americas are shown on the map, brings the user to the "אסיה" ("Asia") section.
Comment 1 Niklas Laxström 2013-01-29 08:34:15 UTC
I recall fixing this particular issue twice before.
Comment 2 Niklas Laxström 2013-02-13 10:16:15 UTC
This time it is overridden by foundation grid CSS.
Comment 3 Amir E. Aharoni 2013-04-10 16:10:14 UTC
I can't reproduce it now. Yair, do you still see it anywhere?
Comment 4 Niklas Laxström 2013-04-10 19:42:56 UTC
Seems to work for me too. I'm curious though which change fixed it.
Comment 5 Amir E. Aharoni 2013-04-10 20:24:57 UTC
(In reply to comment #4)
> Seems to work for me too. I'm curious though which change fixed it.

Me too.

Please reopen if it happens again.
Comment 6 Siebrand Mazeland 2013-04-10 21:01:38 UTC
Is there maybe a behavior difference between ULS as MediaWiki extension and as stand alone component wrt this particular thing?
Comment 7 Amir E. Aharoni 2013-04-10 21:18:59 UTC
I tried both.

The extension is fine.

The standalone version has some little layout issues, but not as described here. Filed as https://github.com/wikimedia/jquery.uls/issues/84 .
Comment 8 Yair Rand 2013-04-11 00:59:48 UTC
(In reply to comment #3)
> I can't reproduce it now. Yair, do you still see it anywhere?
Nope, seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links