Last modified: 2013-12-06 14:39:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 43458 - Error: 23502 ERROR: null value in column "site_id" violates not-null constraint
Error: 23502 ERROR: null value in column "site_id" violates not-null constraint
Status: RESOLVED DUPLICATE of bug 43475
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2012-12-27 10:38 UTC by Aude
Modified: 2013-12-06 14:39 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Aude 2012-12-27 10:38:42 UTC
I am unable to populate the sites table, with patch https://gerrit.wikimedia.org/r/#/c/27939/ (should be perfectly good).

I get the error:
Error: 23502 ERROR:  null value in column "site_id" violates not-null constraint

ORM stuff is still not behaving correctly for PostgreSQL in how it handles the id column.
Comment 1 Marcin Cieślak 2013-12-06 14:39:22 UTC
This is now much better discussed in bug 43475.

*** This bug has been marked as a duplicate of bug 43475 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links