Last modified: 2013-04-22 16:14:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 41114 - No fa_sha1 schema update for PostgreSQL
No fa_sha1 schema update for PostgreSQL
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.21.x
All All
: Normal blocker with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2012-10-17 16:08 UTC by Tim Landscheidt
Modified: 2013-04-22 16:14 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Tim Landscheidt 2012-10-17 16:08:12 UTC
Commit fb2c1c645bdc2f74477e4a4dd9c7b08c5afe4744 added a field filearchive.fa_sha1 to MySQL and SQLite schemas, but not to PostgreSQL.
Comment 1 Andre Klapper 2012-10-18 19:32:32 UTC
[CC'ing the author]
Comment 2 Umherirrender 2012-10-19 15:58:49 UTC
I have no way to test PostgreSQL and/or install that RDBMS.

I have added sqlite only, because jenkins is testing this and will give a failed build.
Comment 3 Tim Landscheidt 2012-10-20 03:44:16 UTC
Gerrit change #28797.  Just to clarify: I didn't want or need Umherirrender to fix this (although help is always welcome :-)), I just wanted other PostgreSQL users and developers (and me :-)) to find that the issue is known and where efforts to solve it are tracked.
Comment 4 Alexandre Emsenhuber [IAlex] 2012-10-20 14:51:41 UTC
And merged.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links