Last modified: 2012-12-21 18:57:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 40384 - HTML validation: Attribute width/height not allowed on element button at this point
HTML validation: Attribute width/height not allowed on element button at this...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.20.x
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 39521 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 11:07 UTC by Gadget850
Modified: 2012-12-21 18:57 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Gadget850 2012-09-20 11:07:04 UTC
Now that HTML5 is enabled, there are two endemic HTML validation errors:

* Attribute width not allowed on element button at this point.
* Attribute height not allowed on element button at this point.

* validator.w3.org/check?uri=http%3A%2F%2Fwww.mediawiki.org%2Fwiki%2FSpecial%3ABlankPage

The issue is in the markup for the search button:
* <button name="button" title="Search Wikipedia for this text" id="searchButton" width="12" height="13">

The width and height attributes are not valid for the button element:
* http://dev.w3.org/html5/spec-author-view/the-button-element.html#the-button-element

The search icon is 12 x 13 pixels, thus this markup is not needed.

HTML validation is important. When editors manually create HTML ids, such as certain citation templates, we recommend they validate the page to ensure they have no duplicates. They get bogged down in endemic validation errors.
Comment 1 Brion Vibber 2012-09-20 21:24:43 UTC
Hmmm...

Looks like UniversalEditButton may or may not have actually adopted the rel="edit" form -- http://universaleditbutton.org/Suggestions#Linking_Scheme lists it and includes a mention of me adding it, but http://universaleditbutton.org/Add_The_Link still lists the rel="alternate" format.

This is the kind of thing that's really meant to be open-ended though, I'm a bit baffled by the idea of rel values being registered. Is that new in HTML5-land?
Comment 2 Brion Vibber 2012-09-20 21:25:05 UTC
Comment on wrong bug. :P
Comment 3 Kevin Israel (PleaseStand) 2012-09-28 03:25:04 UTC
Gerrit change #25606
Comment 4 Bartosz Dziewoński 2012-12-21 18:57:59 UTC
*** Bug 39521 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links