Last modified: 2013-12-01 15:42:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39598 - VisualEditor: Support templates
VisualEditor: Support templates
Status: RESOLVED FIXED
Product: VisualEditor
Classification: Unclassified
General (Other open bugs)
unspecified
All All
: High enhancement
: VE-deploy-2013-06-20
Assigned To: Trevor Parscal
:
: 46520 (view as bug list)
Depends on: 44444 45062 46571 48663
Blocks: ve-plugins-to-create 48426
  Show dependency treegraph
 
Reported: 2012-08-23 22:42 UTC by James Forrester
Modified: 2013-12-01 15:42 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description James Forrester 2012-08-23 22:42:42 UTC

    
Comment 1 Helder 2013-01-05 15:54:22 UTC
Maybe this "Template Parameter Wizard" is of some interest:

http://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)/Archive_103#Template_Parameter_Wizard
Comment 2 James Forrester 2013-03-24 23:28:49 UTC
*** Bug 46520 has been marked as a duplicate of this bug. ***
Comment 3 Quim Gil 2013-03-25 05:01:10 UTC
Phoebe is recommending to Work_on_RefToolbar improvements at
http://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects#Work_on_RefToolbar

However, I wonder whether our focus shouldn't be put in VisualEditor support for the Cite templates, either out of the box or via plugin. Any advice?
Comment 4 phoebe 2013-03-25 20:57:55 UTC
Fair enough. Maybe the project should be "work on citation stuff" broadly -- not sure how to frame that :) There is plenty of work that should overlap between the reftoolbar and the VE, though; like figuring out what citation template parameters need to be used, figuring out how to work with Lua conversions, and so on. I wonder if reftoolbar could be converted into a VE plugin -- the interface is actually pretty good, no need to reinvent the wheel on handling citations.
Comment 5 James Forrester 2013-03-25 21:09:11 UTC
VE will support template editing quite soon (famous last words!) which will replace (alongside the TemplateData extension) pretty much all of what the RefToolbar does in terms of telling users how to use the templates and what each parameter means.

We should certainly look at some accessor functionality to make it easy and obvious when in a reference to know what templates to use, but that would be in longer time.

My concern is that we're currently targetting this landing in the middle of the GSoC period - too late for someone working on GSoC to react to it and extend it, and so soon into the period (and so obviously-about-to-happen) to make working on the area that VE will replace it. :-(
Comment 6 Krinkle 2013-05-15 19:37:58 UTC
Change-Id: I9174ed7c9012522246a6defc859276bf36763f5b
Comment 7 James Forrester 2013-06-19 02:44:50 UTC
The main template editing functionality is now live. Though there are some fixes to make, I'm marking this one as closed.
Comment 8 vladjohn2013 2013-12-01 15:42:23 UTC
Hi, this project is still listed at  https://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects#Work_on_RefToolbar 

Should this project be still listed in that page? If not, please remove it. If it still makes sense, then it could be moved to the "Featured projects" section if it has community support and mentors.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links