Last modified: 2013-09-25 17:37:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 38303 - confusing error message when uploading a file with filename is not allowed: "This title contains some undesirable characters. Please remove them."
confusing error message when uploading a file with filename is not allowed: "...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UploadWizard (Other open bugs)
unspecified
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 43009 (view as bug list)
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2012-07-11 13:42 UTC by matanya
Modified: 2013-09-25 17:37 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description matanya 2012-07-11 13:42:17 UTC
I tried to upload an image with the name: 

זהבה%20001[1].jpg


I got the following error:

The filename is not allowed.

though I know what is the problem with the file name, a new user might not know, and won't be able to proceed as this error doesn't give any hint how to fix the error.

compare to the ole tool message:

The filename "זהבה%20001-1-.jpg" contains characters that are not allowed in page titles. Please rename the file and try uploading it again.
Comment 1 Brion Vibber 2012-07-11 14:19:23 UTC
It may be better still to specify which characters are invalid...

And when auto-generated names turn out to be invalid, something's wrong. :) We should make sure the auto name is always valid or else clearly make it easy to fix.
Comment 2 Nemo 2012-07-25 09:53:55 UTC
(In reply to comment #1)
> It may be better still to specify which characters are invalid...

That looks like another feature request, in the meanwhile matanya's suggestion could be implemented, but I'm not sure that "characters that are not allowed" is the best, given it's not only about characters but also sequences of characters/other regexes.
Comment 3 Derk-Jan Hartman 2012-08-29 22:34:18 UTC
You now have no feedback. Instead your proposed title is automatically 'cleansed' and you have no feedback that your title got changed until after the real upload was executed.

Also not really ideal I think...
Comment 4 Nischay Nahata 2013-03-10 20:33:13 UTC
*** Bug 43009 has been marked as a duplicate of this bug. ***
Comment 5 Brion Vibber 2013-09-25 17:37:07 UTC
Ok, the issue as originally reported is resolved -- the original filename is automatically converted to a suggested filename that removes the '[' and ']' chars, and you don't get a weird error message if you forget to customize the filename.

Resolving as fixed. If there remain concerns about what happens if you then type in a name that's not a valid title or file, please open a separate bug for that.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links