Last modified: 2014-11-12 18:45:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 36635 - language direction conflicts when ltr and rtl text is displayed in parallel
language direction conflicts when ltr and rtl text is displayed in parallel
Status: RESOLVED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
WikidataRepo (Other open bugs)
unspecified
All All
: Low minor with 4 votes (vote)
: ---
Assigned To: Wikidata bugs
: i18n, need-volunteer
: 45932 (view as bug list)
Depends on: 28970
Blocks: rtl-wikidata
  Show dependency treegraph
 
Reported: 2012-05-08 10:46 UTC by Henning
Modified: 2014-11-12 18:45 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screenshots visualizing the issue (39.37 KB, image/png)
2012-05-08 10:46 UTC, Henning
Details

Description Henning 2012-05-08 10:46:31 UTC
Created attachment 10548 [details]
screenshots visualizing the issue

Handling page titles that natively are supposed to inherit the opposing language direction within a global language direction context will result in display and (auto-complete) lookup errors when the title includes certain characters (e.g. with parentheses which do not have an inherent direction).
A solution might be to store the language direction as per site and have direction applied locally to every site/page link. However, sites may contain page titles of ltr and rtl direction.

In the Wikibase repo extension we have a list of all site links. This list contains links to several sites. In a Wikipedia context this is the list of language links to articles in different Wikipedia instances, so it is a list full of mixed language directions which currently is displayed either in a ltr or rtl user interface depending on the user language.

This problem is basically the same as in MediaWiki core when displaying rtl and ltr text in parallel, see for example #28411.
Comment 1 Amir E. Aharoni 2012-05-08 11:42:00 UTC
Bug 28411 is indeed related. More generally, bug 28970 is about indicating directionality (or ideally, language) per page.
Comment 2 Mark A. Hershberger 2012-05-08 14:06:11 UTC
confirming b/c of screenshots and Amir's response.
Comment 3 Aude 2013-06-07 09:56:02 UTC
*** Bug 45932 has been marked as a duplicate of this bug. ***
Comment 4 Thiemo Mättig 2014-05-20 14:31:56 UTC
We just found an interesting occurrence of this bug: https://www.wikidata.org/wiki/Special:Diff/131600143
Comment 5 Gerrit Notification Bot 2014-05-20 17:03:04 UTC
Change 134386 had a related patch set uploaded by Thiemo Mättig (WMDE):
Right-to-left rendering for site links in diff

https://gerrit.wikimedia.org/r/134386
Comment 6 Thiemo Mättig 2014-05-20 17:06:04 UTC
My diff related patch is only very loosely connected to the original problem reported here. It's the same issue but in an other place.
Comment 7 Gerrit Notification Bot 2014-06-02 22:08:06 UTC
Change 134386 merged by Hoo man:
Right-to-left rendering for site links in diff

https://gerrit.wikimedia.org/r/134386
Comment 8 Nemo 2014-11-12 16:28:05 UTC
Some of the test cases were deleted, but https://www.wikidata.org/wiki/Q1765794?uselang=ar#sitelinks-wikipedia looks ok to me. Can this be closed?

The bug in the search suggestion on he.wiki when using he interface language is still present, but has nothing to do with Wikibase. Is that covered by another report?
Comment 9 reza1615 2014-11-12 18:45:03 UTC
https://www.wikidata.org/w/index.php?diff=131600143
and
fa:علی‌آباد (بستان‌آباد) at 
https://www.wikidata.org/wiki/Q4813524?uselang=en
and
https://www.wikidata.org/wiki/Q4813524?uselang=fa
are ok for me

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links