Last modified: 2012-03-23 15:32:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 35410 - RTL mix is strange
RTL mix is strange
Status: RESOLVED DUPLICATE of bug 28970
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Amir E. Aharoni
https://fa.wikipedia.org/w/index.php?...
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2012-03-22 16:24 UTC by Mark A. Hershberger
Modified: 2012-03-23 15:32 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mark A. Hershberger 2012-03-22 16:24:20 UTC
The square brackets around the edit links that result from linked URL (https://fa.wikipedia.org/w/index.php?diff=6411127) are messed up. The parenthesis around the talk link in my signature are also wonky even though they are not immediately followed by a character in Farsi.
Comment 1 Amir E. Aharoni 2012-03-23 05:45:07 UTC
Which part are you talking about?

The appearance of wikitext source in the diff view? There isn't much to do about that currently, although i'd love to have a structured way to say that a section is LTR and should be shown accordingly everywhere, including diff.

Or are your talking about the links to your user page above the diff view? They look OK to me (except "!thanks", which i may consider putting in dir="auto", but that's another issue).

Or are you talking about the actual message as it appears after you save? That's the usual bidi mess, which can be fixed but adding <div class="mw-content-ltr">, and this was already done in a subsequent edit [1] by adding a template. As above, it would be nice to mark a section as ltr in a more structured way, but that will be handled Some Day in Bug 28970 or in the Visual Editor.

Or is it something else that i miss?

[1] https://fa.wikipedia.org/w/index.php?title=User_talk:Reza1615&diff=next&oldid=6411149
Comment 2 Mark A. Hershberger 2012-03-23 15:32:24 UTC
(In reply to comment #1)
> Or are you talking about the actual message as it appears after you save?
> That's the usual bidi mess, which can be fixed but adding <div
> class="mw-content-ltr">, and this was already done in a subsequent edit [1] by
> adding a template. As above, it would be nice to mark a section as ltr in a
> more structured way, but that will be handled Some Day in Bug 28970 or in the
> Visual Editor.

That is exactly what I was talking about.  Marking this a dupe so future developers will have a good example.

*** This bug has been marked as a duplicate of bug 28970 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links