Last modified: 2012-08-27 10:54:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 34679 - Script rendering error when reverting username with Arabic scripts
Script rendering error when reverting username with Arabic scripts
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
History/Diffs (Other open bugs)
1.19
All All
: Low trivial with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2012-02-24 08:05 UTC by bennylin
Modified: 2012-08-27 10:54 UTC (History)
5 users (show)

See Also:
Web browser: Firefox
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screenie for history page on my browser (54.78 KB, image/jpeg)
2012-02-24 08:05 UTC, bennylin
Details
try with devanagri script (59.32 KB, image/jpeg)
2012-03-14 14:00 UTC, bennylin
Details

Description bennylin 2012-02-24 08:05:59 UTC
Created attachment 10086 [details]
screenie for history page on my browser

http://id.wikisource.org/w/index.php?title=Wikisource:Warung_kopi&curid=49&action=history&uselang=en

There's script error when reverting a user with Arabic script username, even though the name itself shows correctly on his edit log.

I assume this is a problem with my browser (FF 3), hence I mark it as trivial. But probably there's an underlying difference on the code for handling non-Latin characters between the two actions.
Comment 1 bennylin 2012-02-24 08:19:12 UTC
Edit:
-okay for IE 6 and IE 9
-okay for Chrome 11 and a little bit funny on Chrome 17
-not displaying (!) on Safari 5.1.1
-extra bold on Opera 11
-okay for FF 10
Comment 2 Lupo 2012-03-14 09:36:34 UTC
Looks fine for me at the given link in both Safari 5.1.2 and FF 3.6.23 on MacOS 10.6.8.
Comment 3 Amir E. Aharoni 2012-03-14 09:44:10 UTC
Hi Benny!

It's probably a Firefox 3 bug, but i'm wondering whether it happens only with Arabic or are other scripts affected, too. Can you try it with other scripts? For example, create the user "बेनि लिन" (that's "Benny Lin" in Devanagari), edit a sandbox using it, and then revert the edit.
Comment 4 bennylin 2012-03-14 13:53:19 UTC
Or probably it depends on a font that hasn't been installed in the particular machine? Because I checked on different Firefox 3.0 yesterday and it was fine. Just curious because obviously the two strings (on the contributor name, and on the revert summary) using different method of displaying Arabic character. Maybe its not Unicode? But I'll try your suggestion, Amir.
Comment 5 bennylin 2012-03-14 14:00:06 UTC
Created attachment 10235 [details]
try with devanagri script
Comment 6 bennylin 2012-03-14 14:01:31 UTC
it's fine with Devanagri. Let's try Arabic or Hebrew, maybe it's because the RTL script.
Comment 7 Santhosh Thottingal 2012-08-27 10:54:10 UTC
I tried to reproduce this bug in FF 3.6(Windos XP SP2 and Ubuntu), FF 14(Windows 7), IE8(WIndows 7)

Results http://crossbrowsertesting.com/users/34057/screenshots/z892a31276a2b6b2fc09/public and http://crossbrowsertesting.com/users/34057/screenshots/za33990113ec51befec7/public

As you can see, script rendering error is not happening. It could be a bug in FF3, but no point in reporting it upstream since it is very very old. And as you pointed out it can be any configuration issue from the OS you tried.

So I am closing it, thanks for reporting the issue.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links